Bug 14358 - Changing the module refreshes the page and resets library choice
Summary: Changing the module refreshes the page and resets library choice
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 22635 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-07 10:02 UTC by Katrin Fischer
Modified: 2019-06-06 17:53 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.05.00, 18.11.05


Attachments
Bug 14358: Changing the module refreshes the page and resets library choice (3.59 KB, patch)
2019-04-04 14:15 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 14358: Changing the module refreshes the page and resets library choice (3.76 KB, patch)
2019-04-05 18:06 UTC, Mikaël Olangcay Brisebois
Details | Diff | Splinter Review
Bug 14358: Changing the module refreshes the page and resets library choice (3.82 KB, patch)
2019-04-06 09:50 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2015-06-07 10:02:21 UTC
This behaviour was originally described on bug 10702.

Whenever you change the module setting for a notice, the page reloads and your chosen branch is reset to all libraries.

Owen made some suggestions about how we can fix this:

- Use Ajax to reload only the field list as Jonathan suggests
- Convert the "New notice" button to a menu which lists the possible
  module choices
- Add an intermediate step where you must submit a module choice
  before rest of the form displays.
Comment 1 Katrin Fischer 2019-04-03 22:05:39 UTC
*** Bug 22635 has been marked as a duplicate of this bug. ***
Comment 2 Owen Leonard 2019-04-04 14:15:50 UTC
Created attachment 87417 [details] [review]
Bug 14358: Changing the module refreshes the page and resets library choice

This patch makes an incremental change towards fixing Bug 14358: The
"New notice" button is converted to a dropdown button which asks the
user to select a module to start with.

To test, apply the patch and go to Tools -> Notices. Test the "New
notice" button and confirm that module selections are reflected in the
notice add form you are shown.
Comment 3 Mikaël Olangcay Brisebois 2019-04-05 18:06:28 UTC
Created attachment 87458 [details] [review]
Bug 14358: Changing the module refreshes the page and resets library choice

This patch makes an incremental change towards fixing Bug 14358: The
"New notice" button is converted to a dropdown button which asks the
user to select a module to start with.

To test, apply the patch and go to Tools -> Notices. Test the "New
notice" button and confirm that module selections are reflected in the
notice add form you are shown.

Signed-off-by: Mikaël Olangcay Brisebois <mikael.olangcay-brisebois@inLibro.com>
Comment 4 Katrin Fischer 2019-04-06 09:50:36 UTC
Created attachment 87466 [details] [review]
Bug 14358: Changing the module refreshes the page and resets library choice

This patch makes an incremental change towards fixing Bug 14358: The
"New notice" button is converted to a dropdown button which asks the
user to select a module to start with.

To test, apply the patch and go to Tools -> Notices. Test the "New
notice" button and confirm that module selections are reflected in the
notice add form you are shown.

Signed-off-by: Mikaël Olangcay Brisebois <mikael.olangcay-brisebois@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Nick Clemens 2019-04-11 13:53:41 UTC
Awesome work all!

Pushed to master for 19.05
Comment 6 Martin Renvoize 2019-04-15 17:37:57 UTC
Pushed to 18.11.x for 18.11.05
Comment 7 Lucas Gass 2019-04-17 22:14:21 UTC
backported to 18.05.x for 18.05.12