Bug 14365 - SQL Reports Last Edit Date column
Summary: SQL Reports Last Edit Date column
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 13047 (view as bug list)
Depends on:
Blocks: 18985
  Show dependency treegraph
 
Reported: 2015-06-08 21:02 UTC by Cab Vinton
Modified: 2017-07-26 02:34 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14365 - Populate never used saved_sql column last_run when execute_query is called (5.83 KB, patch)
2017-02-07 15:58 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14365 - SQL Reports Last Edit Date column - Show in interface (2.29 KB, patch)
2017-02-07 15:59 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14365 - Populate never used saved_sql column last_run when execute_query is called (4.98 KB, patch)
2017-02-07 16:09 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14365 - SQL Reports Last Edit Date column - Show in interface (2.65 KB, patch)
2017-02-07 16:09 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14365 - Change 'Last modified' to 'Last edit' for terseness (1.13 KB, patch)
2017-03-01 11:26 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 14365 - Populate never used saved_sql column last_run when execute_query is called (5.10 KB, patch)
2017-03-14 13:04 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 14365 - SQL Reports Last Edit Date column - Show in interface (2.77 KB, patch)
2017-03-14 13:04 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 14365 - Change 'Last modified' to 'Last edit' for terseness (1.25 KB, patch)
2017-03-14 13:04 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14365 - Populate never used saved_sql column last_run when execute_query is called (5.16 KB, patch)
2017-03-17 15:19 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14365 - SQL Reports Last Edit Date column - Show in interface (2.83 KB, patch)
2017-03-17 15:19 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14365 - Change 'Last modified' to 'Last edit' for terseness (1.31 KB, patch)
2017-03-17 15:19 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Cab Vinton 2015-06-08 21:02:15 UTC
The Saved Reports page currently shows the Creation Date of Reports.

To my way of thinking, it would be much more helpful to have the Last Edit Date displayed & sortable.

When I'm working with Reports I am almost always working on the same few Reports within a relatively short time period & it would be great to have an easy way of retrieving these.

Along the same lines, this would also provide an easy way of identifying which Reports other librarians have been working on most recently.

Cheers!

Cab Vinton
Plaistow Public Library
Comment 1 Kyle M Hall 2017-02-07 15:58:59 UTC
Created attachment 59985 [details] [review]
Bug 14365 - Populate never used saved_sql column last_run when execute_query is called
Comment 2 Kyle M Hall 2017-02-07 15:59:07 UTC
Created attachment 59986 [details] [review]
Bug 14365 - SQL Reports Last Edit Date column - Show in interface
Comment 3 Kyle M Hall 2017-02-07 16:09:47 UTC
Created attachment 59988 [details] [review]
Bug 14365 - Populate never used saved_sql column last_run when execute_query is called
Comment 4 Kyle M Hall 2017-02-07 16:09:54 UTC
Created attachment 59989 [details] [review]
Bug 14365 - SQL Reports Last Edit Date column - Show in interface

Test Plan:
1) Apply these patches
2) Modify a saved sql report
3) Note the "Last modified" column is updated
4) Run the report
5) Note the "Last run" column is updated
Comment 5 Kyle M Hall 2017-03-01 11:26:21 UTC
Created attachment 60752 [details] [review]
Bug 14365 - Change 'Last modified' to 'Last edit' for terseness
Comment 6 Kyle M Hall 2017-03-14 13:04:18 UTC
Created attachment 61060 [details] [review]
[SIGNED-OFF] Bug 14365 - Populate never used saved_sql column last_run when execute_query is called

Signed-off-by: Cab Vinton <director@plaistowlibrary.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 7 Kyle M Hall 2017-03-14 13:04:25 UTC
Created attachment 61061 [details] [review]
[SIGNED-OFF] Bug 14365 - SQL Reports Last Edit Date column - Show in interface

Test Plan:
1) Apply these patches
2) Modify a saved sql report
3) Note the "Last modified" column is updated
4) Run the report
5) Note the "Last run" column is updated

Signed-off-by: Cab Vinton <director@plaistowlibrary.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 8 Kyle M Hall 2017-03-14 13:04:28 UTC
Created attachment 61062 [details] [review]
[SIGNED-OFF] Bug 14365 - Change 'Last modified' to 'Last edit' for terseness

Signed-off-by: Cab Vinton <director@plaistowlibrary.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 9 Jonathan Druart 2017-03-17 15:17:54 UTC
Not blocker but it would have been good to update the prototype of the subroutine to pass a hashref instead of the list of undef...
This new parameter is a bit awkward: if the id is passed, a DB field is updated. Not elegant but given the quality of the existing code it's hard to provide something better...

Passing QA
Comment 10 Jonathan Druart 2017-03-17 15:19:28 UTC
Created attachment 61220 [details] [review]
Bug 14365 - Populate never used saved_sql column last_run when execute_query is called

Signed-off-by: Cab Vinton <director@plaistowlibrary.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 11 Jonathan Druart 2017-03-17 15:19:33 UTC
Created attachment 61221 [details] [review]
Bug 14365 - SQL Reports Last Edit Date column - Show in interface

Test Plan:
1) Apply these patches
2) Modify a saved sql report
3) Note the "Last modified" column is updated
4) Run the report
5) Note the "Last run" column is updated

Signed-off-by: Cab Vinton <director@plaistowlibrary.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 12 Jonathan Druart 2017-03-17 15:19:38 UTC
Created attachment 61222 [details] [review]
Bug 14365 - Change 'Last modified' to 'Last edit' for terseness

Signed-off-by: Cab Vinton <director@plaistowlibrary.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 13 Kyle M Hall 2017-03-31 14:35:19 UTC
Pushed to master for 17.05!
Comment 14 Katrin Fischer 2017-04-02 17:43:35 UTC
This won't get ported back to 16.11.x as it is an enhancement.
Comment 15 Nick Clemens 2017-07-26 02:28:52 UTC
*** Bug 13047 has been marked as a duplicate of this bug. ***