Bug 14404 - Checkouts default sort order for Self Checkout (SCO) confusing for patrons
Summary: Checkouts default sort order for Self Checkout (SCO) confusing for patrons
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Self checkout (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 12014 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-17 13:24 UTC by Kyle M Hall
Modified: 2017-06-14 22:11 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14404 - Checkouts default sort order for Self Checkout (SCO) confusing for patrons (3.85 KB, patch)
2015-06-17 13:28 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14404 - Checkouts default sort order for Self Checkout (SCO) confusing for patrons (3.90 KB, patch)
2015-06-17 23:03 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 14404 [QA Followup] - Rename class nosort to no-sort for readability and consistency (1.82 KB, patch)
2015-07-08 14:16 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14404 - Checkouts default sort order for Self Checkout (SCO) confusing for patrons (3.97 KB, patch)
2015-07-09 09:32 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14404: Rename class no-show to noshow for consistency with nosort (1.80 KB, patch)
2015-07-09 09:32 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2015-06-17 13:24:20 UTC
Libraries are reporting that patrons are very confused during self-checkout. The problem is they are expecting the list of checkouts to be in the order they checked out the items ( first checkout on the bottom, last item checked out on top ). However, the checkouts table is sorted by title ( ascending ) then due date ( descending ). This is not intuitive.
Comment 1 Kyle M Hall 2015-06-17 13:28:21 UTC Comment hidden (obsolete)
Comment 2 M. Tompsett 2015-06-17 23:03:39 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-06-18 08:11:07 UTC
Sorry but I think it's better to keep consistency between "no-show" and "nosort".
Comment 4 Kyle M Hall 2015-07-08 14:16:03 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2015-07-09 09:32:33 UTC
Created attachment 40861 [details] [review]
Bug 14404 - Checkouts default sort order for Self Checkout (SCO) confusing for patrons

Libraries are reporting that patrons are very confused during
self-checkout. The problem is they are expecting the list of checkouts
to be in the order they checked out the items ( first checkout on the
bottom, last item checked out on top ). However, the checkouts
table is sorted by title ( ascending ) then due date ( descending ).
This is not intuitive.

Test Plan:
1) Enable Koha's self checkout
2) Use the SCO to check out a random assortment of items,
   make sure you don't check them out in alphabetical order
3) Note the order of the items in the list is not based on the order
   you checked them out in
4) Apply this patch
5) Refresh the page
6) Note the items are now in the order you checked them out
   with the last on top and the first on bottom

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@koha-community.org>
Comment 6 Jonathan Druart 2015-07-09 09:32:48 UTC
Created attachment 40862 [details] [review]
Bug 14404: Rename class no-show to noshow for consistency with nosort

Signed-off-by: Jonathan Druart <jonathan.druart@koha-community.org>
Comment 7 Jonathan Druart 2015-07-09 09:35:40 UTC
(In reply to Kyle M Hall from comment #4)
> Created attachment 40832 [details] [review] [review]
> Bug 14404 [QA Followup] - Rename class nosort to no-sort for readability and
> consistency

I am against this patch, the "nosort" already exists in other places.

Tomas, either 1/ you push my patch to get consistency between nosort (existented before this patch and in other places) or 2/ don't push it for readability and we will need to fix the existent occurrences of nosort.
Comment 8 Tomás Cohen Arazi 2015-07-20 14:05:26 UTC
Patches pushed to master.

Thanks Kyle and Jonathan!
Comment 9 Chris Cormack 2015-08-04 21:16:18 UTC
Pushed to 3.20.x will be in 3.20.3
Comment 10 Liz Rea 2015-08-11 02:00:43 UTC
Pushed to 3.18.x, will be in 3.18.10.
Comment 11 Ian Palko 2015-12-02 19:35:11 UTC
*** Bug 12014 has been marked as a duplicate of this bug. ***