Bug 14450 - Stricter template name rules cause itemsearch to stop working
Summary: Stricter template name rules cause itemsearch to stop working
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 14679 (view as bug list)
Depends on: 14408
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-24 09:55 UTC by Liz Rea
Modified: 2016-12-05 21:22 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
bug 14450 - itemsearch no longer working (2.37 KB, patch)
2015-06-24 09:57 UTC, Liz Rea
Details | Diff | Splinter Review
bug 14450 - itemsearch no longer working (2.44 KB, patch)
2015-06-24 10:12 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 14450 - itemsearch no longer working (2.44 KB, patch)
2015-06-24 10:13 UTC, Jacek Ablewicz
Details | Diff | Splinter Review
Bug 14450 - itemsearch no longer working (2.49 KB, patch)
2015-06-24 10:16 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 14450 - itemsearch no longer working (2.56 KB, patch)
2015-06-24 10:33 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2015-06-24 09:55:27 UTC
Another side effect of this patches is that item search gets broken (3.18.x and up seems to be affected), because we have at least two templates like this:

   - catalogue/itemsearch.json.tt
   - catalogue/itemsearch.csv.tt


Originally reported by Jacek Ablewicz
Comment 1 Liz Rea 2015-06-24 09:57:19 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2015-06-24 10:12:53 UTC Comment hidden (obsolete)
Comment 3 Jacek Ablewicz 2015-06-24 10:13:23 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2015-06-24 10:14:42 UTC
(In reply to Jacek Ablewicz from comment #3)
> Signed-off-by: Jacek Ablewicz <abl@biblos.pk.edu.pl>

Hehe, too slow Jacek ;)
Comment 5 Jonathan Druart 2015-06-24 10:16:56 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-06-24 10:33:43 UTC
Created attachment 40570 [details] [review]
[PASSED QA] Bug 14450 - itemsearch no longer working

To test:
Click Advanced search in staff client
Click the link for "Go to Item Search" at the top of the page
Do a search, you should get results. Try some combinations and make sure it works like it should.

Signed-off-by: Jacek Ablewicz <abl@biblos.pk.edu.pl>

Signed-off-by: Jonathan Druart <jonathan.druart@koha-community.org>
Signed-off-by: Katrin Fischer <katrin.fischer@bsz-bw.de>
Comment 7 Tomás Cohen Arazi 2015-06-24 14:34:42 UTC
Patch pushed to master.

Thanks Liz!
Comment 8 Chris Cormack 2015-06-25 21:05:36 UTC
Pushed to 3.20.x will be in 3.20.2
Comment 9 Liz Rea 2015-07-20 21:57:08 UTC
Pushed to 3.18.x, will be in 3.18.09
Comment 10 Anthony Moore 2015-08-14 06:45:26 UTC
*** Bug 14679 has been marked as a duplicate of this bug. ***