Bug 14676 - UI/UX enhancements for the patron card creator
Summary: UI/UX enhancements for the patron card creator
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Liz Rea
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 14131 14632 15112 15663
  Show dependency treegraph
 
Reported: 2015-08-12 22:44 UTC by Liz Rea
Modified: 2017-06-14 22:08 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14676 - UI/UX improvements to patron card creator (40.91 KB, patch)
2015-10-14 02:31 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 14676 - UI/UX improvements to patron card creator (41.11 KB, patch)
2015-10-14 21:40 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 14676 - UI/UX improvements to patron card creator (41.16 KB, patch)
2015-10-15 11:00 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14676: (QA followup) remove useless patroncards-menu.inc file (4.16 KB, patch)
2015-10-20 18:24 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14676: (QA followup) Make title, breadcrumbs and labels consistent (10.88 KB, patch)
2015-10-20 18:24 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14676: (QA followup) Fix case problems carried from the past (2.31 KB, patch)
2015-10-20 18:24 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2015-08-12 22:44:48 UTC
This interface could use the same kind of love that the label creator is getting, as it has a similar UI structure to the label creator tool.
Comment 1 Liz Rea 2015-10-14 02:31:20 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2015-10-14 04:02:29 UTC
Hi Liz,

Great! (However I could not yet test).

I note here following Bug because I think it will depend from that one:

Bug 14131 - Patroncard: Add possibility to print from patron lists

Marc
Comment 3 Liz Rea 2015-10-14 08:39:42 UTC
Hmm, yes.

I'll have a look at your patch and see what I see.

Cheers,
Liz
Comment 4 Marc Véron 2015-10-14 21:40:19 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2015-10-15 11:00:23 UTC
Created attachment 43426 [details] [review]
Bug 14676 - UI/UX improvements to patron card creator

Reasoning

Librarians will be doing patron card things in the following frequencies, from most frequent to least frequent:
1. Creating new patron card batches - every day/every few days
2. Managing existing card batches - every day/every few days
3. Managing existing card layouts - as needed, infrequent
5. Managing existing card templates - as needed, infrequent
6. Creating new card layouts - as needed, infrequent
7. Creating new card templates - as needed, infrequent
8. Managing existing printer profiles - possibly once only!
9. Creating new printer profiles - possibly once only!

This change to the patron card creator aims to make the most frequently used items easily accessible at the top of the main area,
reduces clutter on the page, and makes the label creator fall in line with UI paradigms found elsewhere in Koha.
I think I've also improved the translatability here somewhat, please check that.

To test:

Open the patron card creator: More -> Tools -> Patron card creator
Note that the toolbar has changed. It should be consistent across all of the patron card creator (it is an include).

+ New menu:

patron card batch
1. make sure it looks ok - toolbar buttons are consistent at the top of the main block.
2. add patrons both by borrowernumber, and by search
3. note that the usual buttons have moved below the textarea, and now have icons.
4. delete and export single patrons using the buttons corresponding to each patron
5. select multiple and use the buttons above the table to remove and export selected patrons
6. export a full batch
7. deduplicate a batch
There should be no regressions in functionality.

Image
1. This menu item should take you directly to the upload/delete images interface
2. Upload an image, note success message is now below the form, eliminating the jumping box.
3. Delete single images using the buttons
4. Delete multiple images using the tickboxes and "Delete selected"
5. Not deletion success message is below the table, eliminating the jumping box.

Layout
1. This menu item should take you directly to the "Edit layout" screen.
2. no functional changes here.
3. note toolbar at top is consistent

Card template
1. this menu item should take you directly to the "Edit patron card template" page.
2. no functional changes here.
3. note toolbar at top is consistent.

Printer profile
1. this menu item should take you directly to the "Edit printer profile" page.
2. no functional changes here.
3. note toolbar at top is consistent.

+ Manage menu:

Card batches
1. This menu item should take you directly to the "currently available batches" page.
2. select a batch to edit using the buttons - it should take you to the editing interface
3. select a batch to delete using the buttons - it should ask for confirm.
4. select several batches using the tickboxes, and select Export selected. Batches should be exported as normal.
5. note toolbar at top is consistent.

Images (this is actually the same page as on the new menu, I included it in both because it does both functions - can change if requested)
1. This menu item should take you directly to the upload/delete images interface
2. Upload an image, note success message is now below the form, eliminating the jumping box.
3. Delete single images using the buttons
4. Delete multiple images using the tickboxes and "Delete selected"
5. Not deletion success message is below the table, eliminating the jumping box.

Layouts
1. This menu item should take you directly to the "currently available layouts" page.
2. select a layout to edit using the buttons
3. select a layout to delete using the buttons
4. note toolbar at top is consistent.

Card templates
1. This menu item should take you directly to the "currently available templates" page.
2. select a template to edit using the buttons
3. select a template to delete using the buttons
4. note toolbar at top is consistent.

Printer profiles
1. This menu item should take you directly to the "currently available profiles" page.
2. select a profile to edit using the buttons
3. select a profile to delete using the buttons
4. note toolbar at top is consistent

+ General
* note that sidebar now only has "labels home" instead of the full "manage" list. It seemed redundant with the toolbar tidied up.

Please note that I am happy to take suggestions/amendments to these changes.

Followed test plan, behaves as advertised.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 6 Jonathan Druart 2015-10-15 11:02:18 UTC
Note there is maybe something not very consistent: The New > Image and Manage > Image link point to the same page.
Comment 7 Liz Rea 2015-10-15 19:56:59 UTC
I mentioned that in the patch notes :)

The page does both functions, here was my reasoning.

When I was working on this, I noticed that the images function basically stands alone. Because it adds images for patron cards, I first added it to the "New" menu, then went away and did other things.

When I came back to do the manage menu, I was personally surprised that it wasn't there in the manage menu. If I want to manage things, wouldn't I click on the manage menu and expect to find the interface to manage images there? So I wondered if other people would be surprised that there wasn't a manage interface too (even though they are the same page). When I put the same link in the Manage menu, it felt right to me. Balanced. Even though technically we are putting a link to the same place in two places. 

I want people to be able to expect that they will find what they are looking for in the place they think it might be, so that's why I did it that way.

There might be another way to do it - we could make a link in the sidebar menu, but that would be a departure from the way the Label Creator works now and would be an inconsistency in itself. Or maybe you have an idea on how to do it differently, I'm completely open to suggestions.

Cheers,
Liz
Comment 8 Tomás Cohen Arazi 2015-10-20 18:24:10 UTC
Created attachment 43661 [details] [review]
Bug 14676: (QA followup) remove useless patroncards-menu.inc file

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 9 Tomás Cohen Arazi 2015-10-20 18:24:14 UTC
Created attachment 43662 [details] [review]
Bug 14676: (QA followup) Make title, breadcrumbs and labels consistent

It does so by slightly changing the naming schema, in line with bug 14667
changes.

It also corrects a minor bug in the breadcrumbs for printer profiles.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 10 Tomás Cohen Arazi 2015-10-20 18:24:18 UTC
Created attachment 43663 [details] [review]
Bug 14676: (QA followup) Fix case problems carried from the past

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 11 Tomás Cohen Arazi 2015-10-20 18:27:08 UTC
Patches pushed to master.

Thanks Liz!