Bug 14952 - web installer database errors on 3.18.11
Summary: web installer database errors on 3.18.11
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: 3.18
Hardware: PC Linux
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-04 18:45 UTC by Bob Ewart
Modified: 2017-06-14 22:12 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Ewart 2015-10-04 18:45:38 UTC
Installing Koha 3.18.11 built from the tar ball on openSuse 13.2.

Select all optional data in step 3.

optional data added
sample_patrons.sql
ERROR 1048 (23000) at line 1: Column 'address' cannot be null 

mandatory data added

authorities_normal_marc21.sql
ERROR 1366 (22007) at line 270: Incorrect integer value: '' for column 'linkid' at row 1 

The build used all the defaults except for 'icu' and the passwords.
Comment 1 Bob Ewart 2015-10-08 17:58:27 UTC
As Liz Rea reported on the mailing list, this problem is caused by the "STRICT_TRANS_TABLES" settings.

If you turn it off, all the data is created as it should be
Comment 2 Bob Ewart 2015-10-08 17:59:38 UTC
As Liz Rea reported on the mailing list, this problem is caused by the "STRICT_TRANS_TABLES" settings.

If you turn it off, all the data is created as it should be
Comment 3 Liz Rea 2015-11-12 21:53:43 UTC
I'll have a look into this thank you for your report.

CHeers,
Liz
Comment 4 Owen Leonard 2016-06-21 13:37:16 UTC
Is this bug valid for any version more recent than 3.18.x? If not please close it.
Comment 5 Jonathan Druart 2016-08-16 08:42:27 UTC
This bug is (will) certainly fixed by bug 16403, bug 16573 and/or bug 16554.