Bug 15119 - Hide search header text boxes on render
Summary: Hide search header text boxes on render
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low trivial (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-03 22:38 UTC by Christopher Brannon
Modified: 2016-12-05 21:25 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15119: Hide search header text boxes on render (2.41 KB, patch)
2016-01-06 13:13 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15119: Hide search header text boxes on render (2.50 KB, patch)
2016-01-06 23:33 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 15119: Hide search header text boxes on render (2.58 KB, patch)
2016-03-10 15:21 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 15119: Hide search header text boxes on render (2.59 KB, patch)
2016-03-11 07:30 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 15119: Hide search header text boxes on render (2.66 KB, patch)
2016-03-20 20:32 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Brannon 2015-11-03 22:38:59 UTC
The whole multiple textboxes in the search header showing while the page is rendering is getting old.  Could someone please set all forms except for the first form in the search header to hidden initially, rather than waiting for the page to load before hiding them?  That would be wonderful!

Christopher
Comment 1 Jonathan Druart 2016-01-06 13:13:17 UTC Comment hidden (obsolete)
Comment 2 Héctor Eduardo Castro Avalos 2016-01-06 23:21:36 UTC
Hi Jonathan, I have an old computer and always render slowly, but i can't reproduce the issue, or I misunderstand the main problem.

Regards
Comment 3 Héctor Eduardo Castro Avalos 2016-01-06 23:29:29 UTC
(In reply to Héctor Eduardo Castro Avalos from comment #2)
> Hi Jonathan, I have an old computer and always render slowly, but i can't
> reproduce the issue, or I misunderstand the main problem.
> 
> Regards

Ahh... Ok I needed to delete my cookies.
Comment 4 Héctor Eduardo Castro Avalos 2016-01-06 23:33:00 UTC
Or erase my browsing history
Comment 5 Héctor Eduardo Castro Avalos 2016-01-06 23:33:42 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2016-01-07 08:45:36 UTC
Thanks for testing Héctor.
Switch back to Needs Signoff, I would like to get one from Christopher.
Comment 7 Héctor Eduardo Castro Avalos 2016-01-08 03:39:29 UTC
(In reply to Jonathan Druart from comment #6)
> Thanks for testing Héctor.
> Switch back to Needs Signoff, I would like to get one from Christopher.

Okidoki
Comment 8 Marc Véron 2016-02-22 10:10:56 UTC
What is the status of this bug?
Comment 9 Jonathan Druart 2016-02-22 11:52:47 UTC
(In reply to Marc Véron from comment #8)
> What is the status of this bug?

Needs Signoff, I would like to get one from Christopher.
Comment 10 Owen Leonard 2016-03-10 15:21:58 UTC Comment hidden (obsolete)
Comment 11 Christopher Brannon 2016-03-10 15:44:38 UTC
I see no change with patch applied.  Attaching video to patch to show my results.

Christopher
Comment 12 Christopher Brannon 2016-03-10 15:45:49 UTC
Actually, I did a screencast.  You can see the results here: http://screencast.com/t/eP9RRvUp

Christopher
Comment 13 Jonathan Druart 2016-03-10 16:06:40 UTC
Seems to work for me on sandbox6, confirm you have correctly flushed your browser cache.
Comment 14 Christopher Brannon 2016-03-10 21:24:26 UTC
(In reply to Jonathan Druart from comment #13)
> Seems to work for me on sandbox6, confirm you have correctly flushed your
> browser cache.

Ugh!  Stupid cache.  It works now.  :/  I'll sign off on it.

Christopher
Comment 15 Jonathan Druart 2016-03-11 07:30:31 UTC Comment hidden (obsolete)
Comment 16 Katrin Fischer 2016-03-20 20:32:03 UTC
Created attachment 49344 [details] [review]
[PASSED QA] Bug 15119: Hide search header text boxes on render

When the page rendering is slow or the page is heavy, the tabs in the
header shown be not correctly displayed as tabs.

This patch suggests to hide them, display the first one, and wait for
the JS code to display them nicely.

To easily reproduced the ergonomic issue, go on the circulation home
page (/cgi-bin/koha/circ/circulation.pl) and search for a patron 'a' or
'd', you will get a lot of result and the page will be slow to be fully
displayed.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Christopher Brannon <cbrannon@cdalibrary.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 17 Brendan Gallagher 2016-03-23 00:02:38 UTC
Pushed to Master - Should be in the May 2016 release.  Thanks!
Comment 18 Julian Maurice 2016-03-23 09:20:27 UTC
Patch pushed to 3.22.x, will be in 3.22.5
Comment 19 Frédéric Demians 2016-03-23 12:52:56 UTC
Pushed to 3.20.x, will be in 3.20.10