Bug 15179 - Marc field 084 does not show on bibliographic record
Summary: Marc field 084 does not show on bibliographic record
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Karen
QA Contact: Testopia
URL:
Whiteboard:
Keywords: Academy
Depends on:
Blocks:
 
Reported: 2015-11-12 12:01 UTC by Krister
Modified: 2017-05-14 10:26 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Marc preview and bibliographic record. 084 is shown in Marc but not on the bibliographic record. (15.81 KB, image/png)
2015-11-12 12:01 UTC, Krister
Details
Bug 15179 -Field 084 doesnt show on bibliographic record (3.01 KB, patch)
2017-01-18 02:23 UTC, Karen
Details | Diff | Splinter Review
Bug 15179 -Field 084 doesnt show on bibliographic record (3.01 KB, patch)
2017-01-18 02:25 UTC, Karen
Details | Diff | Splinter Review
Bug 15179 -Field 084 doesnt show on bibliographic record (3.07 KB, patch)
2017-01-20 15:21 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 15179 -Field 084 doesnt show on bibliographic record (3.12 KB, patch)
2017-04-28 20:11 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 15179 (QA Followup) Fix comments to 'other classification' (1.58 KB, patch)
2017-04-28 20:11 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Krister 2015-11-12 12:01:00 UTC
Created attachment 44796 [details]
Marc preview and bibliographic record. 084 is shown in Marc but not on the bibliographic record.

In Sweden we use field 084 in marc to store the classification code. 

In Koha the 084 field does not show on the bibliographic record. This pertains both the staff client and the opac.  

I tried to leave the XSLTDetailsDisplay-field blank in administration, but it's the same result.
Comment 1 Katrin Fischer 2015-11-12 14:08:28 UTC
Hi Krister, thx for filing a bug report. I am changing this to enh, because it's not a bug per definition. But it's certainly worth adding to the XSLT displays. The normal view that you see when you leave the XSLT prefs empty is no longer actively maintained and missing a lot of information - I'd recommend sticking with the default XSLT.

Btw - not only in Sweden :) 084 is used whenever you have something that didn't end up having it's own field, like DDC or UDC have.
Comment 2 Karen 2017-01-18 02:23:40 UTC
Created attachment 59134 [details] [review]
Bug 15179 -Field 084 doesnt show on bibliographic record
Comment 3 Karen 2017-01-18 02:25:06 UTC
Created attachment 59135 [details] [review]
Bug 15179 -Field 084 doesnt show on bibliographic record
Comment 4 Karen 2017-01-18 02:30:51 UTC
Test Plan

Make sure the editor is checked for 084 in MARC frameworks
Edit field 084
Save the record and confirm that the note does not show up in staff client or opac
Apply patch and refresh page
Field 084 should now show up in staff client and opac
Comment 5 Mirko Tietgen 2017-01-20 15:21:29 UTC
Created attachment 59380 [details] [review]
Bug 15179 -Field 084 doesnt show on bibliographic record

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Comment 6 Mirko Tietgen 2017-01-20 15:22:43 UTC
Karen, thanks for your patch! One tiny thing: in the comment (first line) you copied "DDC Classification". You could change this to "Other classification" in a follow-up patch.
Comment 7 Nick Clemens 2017-04-28 20:11:14 UTC
Created attachment 62870 [details] [review]
Bug 15179 -Field 084 doesnt show on bibliographic record

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 8 Nick Clemens 2017-04-28 20:11:17 UTC
Created attachment 62871 [details] [review]
Bug 15179 (QA Followup) Fix comments to 'other classification'
Comment 9 Kyle M Hall 2017-05-12 14:36:15 UTC
Pushed to master for 17.05, thanks Karen, Nick!
Comment 10 Katrin Fischer 2017-05-14 10:26:42 UTC
This won't get ported back to 16.11.x as it is an enhancement.