Bug 15211 - Label/patron card creators need to have Tools sidebar
Summary: Label/patron card creators need to have Tools sidebar
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Liz Rea
QA Contact: Testopia
URL:
Keywords:
: 15212 (view as bug list)
Depends on:
Blocks: 15213
  Show dependency treegraph
 
Reported: 2015-11-18 22:21 UTC by Liz Rea
Modified: 2017-06-14 22:05 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15211 - adding Tools section sidebar to label creator (6.31 KB, patch)
2015-11-19 01:31 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 15211 - Patron card creator needs tools sidebar (5.94 KB, patch)
2015-11-19 02:16 UTC, Liz Rea
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15211: adding Tools section sidebar to label creator (6.41 KB, patch)
2015-11-19 02:55 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15211: Patron card creator needs tools sidebar (6.04 KB, patch)
2015-11-19 02:55 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 15211: adding Tools section sidebar to label creator (6.47 KB, patch)
2015-11-25 16:05 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15211: Patron card creator needs tools sidebar (6.10 KB, patch)
2015-11-25 16:05 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2015-11-18 22:21:43 UTC
As tools, it would be nice to have the tools sidebar on these pages. Especially since there is currently nothing there.
Comment 1 Liz Rea 2015-11-19 01:31:31 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2015-11-19 02:16:30 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2015-11-19 02:17:24 UTC
Note that the 2nd patch depends on the first one.
Comment 4 Héctor Eduardo Castro Avalos 2015-11-19 02:55:08 UTC Comment hidden (obsolete)
Comment 5 Héctor Eduardo Castro Avalos 2015-11-19 02:55:23 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2015-11-25 16:05:16 UTC
Created attachment 45150 [details] [review]
Bug 15211: adding Tools section sidebar to label creator

The label creator had a very sad sidebar, it needed to have the Tools area sidebar on it.

To test:

Click through all "New" pages, verify that the sidebar appears
Click through all "Manage" pages, verify that the sidebar appears.

Also verify that "Label creator" is bolded in the toolbar while the label creator is active.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Sidebar displayed Ok. No errors

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 7 Jonathan Druart 2015-11-25 16:05:20 UTC
Created attachment 45151 [details] [review]
Bug 15211: Patron card creator needs tools sidebar

The patron card creator should have the Tools area sidebar on its pages. This patch adds it.

To test:
Go to More -> Tools -> Patron card creator

The home page should have the tools sidebar
Click through all of the "New" pages - they should all have the tools sidebar
Click through all of the "Manage" pages - they should all have the tools sidebar

Also verify that on each page, the Patron card creator link in the sidebar is bolded

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Sidebar displayed Ok. No errors

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Liz Rea 2015-12-02 00:38:41 UTC
*** Bug 15212 has been marked as a duplicate of this bug. ***
Comment 9 Kyle M Hall 2015-12-31 15:02:36 UTC
Pushed to master, thanks Liz!