Bug 15568 - Circ rules are not displayed anymore
Summary: Circ rules are not displayed anymore
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 11625 15295
Blocks: 15581
  Show dependency treegraph
 
Reported: 2016-01-13 16:13 UTC by Jonathan Druart
Modified: 2016-12-05 21:23 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15568: Fix display default circ rules (1.53 KB, patch)
2016-01-13 16:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15568: Fix display default circ rules (1.66 KB, patch)
2016-01-14 17:14 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 15568: Fix display default circ rules (1.85 KB, patch)
2016-01-14 17:14 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 15568: Fix display default circ rules (1.58 KB, patch)
2016-01-14 17:32 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 15568 (Follow up) (1.13 KB, patch)
2016-01-14 17:33 UTC, Nick Clemens
Details | Diff | Splinter Review
^# Attachment to Bug 15568 - Circ rules are not displayed anymore (1.65 KB, text/plain)
2016-01-15 03:22 UTC, Aleisha Amohia
Details
Bug 15568: Fix display default circ rules (1.61 KB, patch)
2016-01-15 09:49 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 15568: Fix display default circ rules (1.68 KB, patch)
2016-01-15 13:52 UTC, Nick Clemens
Details | Diff | Splinter Review
[PASSED QA] Bug 15568: Fix display default circ rules (1.68 KB, patch)
2016-01-18 22:13 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-01-13 16:13:33 UTC
When changing the library from specific to all, the rules are not displayed anymore on the circ rules admin table.

git bisect blames:
  commit 83e913f8c26a815019ffde21524cc7f126357d57
    Bug 11625 - Implement DefaultToLoggedInLibraryCircRules
Comment 1 Jonathan Druart 2016-01-13 16:15:38 UTC Comment hidden (obsolete)
Comment 2 Nick Clemens 2016-01-14 17:14:00 UTC Comment hidden (obsolete)
Comment 3 Nick Clemens 2016-01-14 17:14:50 UTC Comment hidden (obsolete)
Comment 4 Nick Clemens 2016-01-14 17:32:53 UTC Comment hidden (obsolete)
Comment 5 Nick Clemens 2016-01-14 17:33:24 UTC Comment hidden (obsolete)
Comment 6 Aleisha Amohia 2016-01-15 03:22:37 UTC Comment hidden (obsolete)
Comment 7 Aleisha Amohia 2016-01-15 03:24:24 UTC
Sorry, I'm not really sure what I just did, but I was meant to be signing off on both patches.
Comment 8 Jonathan Druart 2016-01-15 09:46:27 UTC
I have submitted a patch on bug 14295 to remove the GetBranchesCount occurrences.
Comment 9 Jonathan Druart 2016-01-15 09:49:59 UTC Comment hidden (obsolete)
Comment 10 Jonathan Druart 2016-01-15 09:53:11 UTC
Nick, I have moved the GetBranchesCount changes as a followup of bug 14295 (because there are 2 occurrences to fix).
So I mark this fix as dependent on it and switch back to needs signoff.
Sorry for the additional work.
Comment 11 Nick Clemens 2016-01-15 13:52:03 UTC Comment hidden (obsolete)
Comment 12 Katrin Fischer 2016-01-18 07:00:16 UTC
Hm, dependencies are pushed to master, but patch doesn't apply for me:

Apply? [(y)es, (n)o, (i)nteractive] y
Applying: Bug 15568: Fix display default circ rules
fatal: sha1 information is lacking or useless (admin/smart-rules.pl).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Comment 13 Jonathan Druart 2016-01-18 11:30:20 UTC
(In reply to Katrin Fischer from comment #12)
> Hm, dependencies are pushed to master, but patch doesn't apply for me:

You must apply the last patch on bug 15295, not pushed to master yet.

[SIGNED-OFF] Bug 15295: (follow-up) Koha::Libraries - Remove GetBranchesCount
Comment 14 Katrin Fischer 2016-01-18 11:35:03 UTC
Tricky!
Comment 15 Katrin Fischer 2016-01-18 22:13:12 UTC
Created attachment 46827 [details] [review]
[PASSED QA] Bug 15568: Fix display default circ rules

To reproduce:
Go on the admin circ rules page (admin/smart-rules.pl), switch the
dropdown list from specific to "all libraries".
The rules are not displayed anymore.

Test plan:
Apply this patch and confirm that the rules are now displayed correctly.
Make sure the enh introduced by bug 11625 is not broken.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 16 Jesse Weaver 2016-01-19 22:37:58 UTC
Pushed to master, thanks for your work!
Comment 17 Julian Maurice 2016-02-01 16:46:42 UTC
This bug does not concern stable versions, changing status to RESOLVED