Bug 15811 - Redirect after adding a new list in OPAC broken
Summary: Redirect after adding a new list in OPAC broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Lists (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords: regression
Depends on: 4912 15810
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 14:53 UTC by Katrin Fischer
Modified: 2017-06-14 22:10 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15811: follow-up Bug 4912: Redirect to the appropriate view after editing/deleting a list (2.61 KB, patch)
2016-02-12 15:31 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15811: follow-up Bug 4912: Redirect to the appropriate view after editing/deleting a list (2.71 KB, patch)
2016-02-12 16:58 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 15811: follow-up Bug 4912: Redirect to the appropriate view after editing/deleting a list (2.74 KB, patch)
2016-02-19 13:54 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2016-02-12 14:53:02 UTC
When adding a new list in the OPAC you are not redirected to the list. 

This seems to be a regression between 3.22.2 and 3.22.3, maybe related to 4912.
Comment 1 Jonathan Druart 2016-02-12 15:31:29 UTC Comment hidden (obsolete)
Comment 2 Héctor Eduardo Castro Avalos 2016-02-12 16:58:48 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2016-02-19 13:54:33 UTC
Created attachment 48233 [details] [review]
Bug 15811: follow-up Bug 4912: Redirect to the appropriate view after editing/deleting a list

Test plan:
1/ At the opac, go on the the list home page (opac-shelves.pl)
2/ Click on 'new list', create a list and save
=> You should be redirect to the list
3/ Click on edit, save
=> You should be redirect to the list
4/ Delete the list
=> You should be redirect to the list
5/ Edit a list from the list view, save
=> You should be redirect to the list
6/ Click on a list link (op=view)
7/ Edit the list, save
=> You should be redirect to the 'show' view
8/ Delete list
=> You should be redirect to the list

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 4 Brendan Gallagher 2016-02-24 01:45:57 UTC
pushed to Master - Should be in the May 2016 Release.  Thanks
Comment 5 Julian Maurice 2016-02-26 15:33:37 UTC
Patch pushed to 3.22.x, will be in 3.22.4