Bug 15925 - Correct some markup issues with patron lists pages
Summary: Correct some markup issues with patron lists pages
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on: 15916
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 14:31 UTC by Owen Leonard
Modified: 2017-06-14 22:11 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15925 - Correct some markup issues with patron lists pages (6.05 KB, patch)
2016-02-29 16:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 15925 [Revised] Correct some markup issues with patron lists pages (5.71 KB, patch)
2016-02-29 16:55 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 15925 [Revised] Correct some markup issues with patron lists pages (5.88 KB, patch)
2016-03-03 09:14 UTC, Frédéric Demians
Details | Diff | Splinter Review
Bug 15925 [Revised] Correct some markup issues with patron lists pages (5.95 KB, patch)
2016-03-03 09:26 UTC, Jonathan Druart
Details | Diff | Splinter Review
[3.22.x] Bug 15925: Correct some markup issues with patron lists pages (5.62 KB, patch)
2016-03-07 13:06 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2016-02-26 14:31:16 UTC
There are some markup issues with the patron lists templates which I would like to correct. I'm marking this bug dependent on Bug 15916 because the JS errors will make it hard to test properly.
Comment 1 Owen Leonard 2016-02-29 16:24:59 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2016-02-29 16:55:58 UTC Comment hidden (obsolete)
Comment 3 Frédéric Demians 2016-03-03 09:14:59 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2016-03-03 09:26:00 UTC
Created attachment 48609 [details] [review]
Bug 15925 [Revised] Correct some markup issues with patron lists pages

This patch makes some markup changes to the patron lists interface in
order to make them more consistent with other areas of Koha.

Change to look for when testing:

Tools -> Patron lists:

- Wrap "New patron list" button in standard <div id="toolbar">
- Place toolbar above page heading.

Tools -> Patron lists -> New patron list:

- Use built-in form validation for required fields
- Clarify page title and breadcrumbs on list add and edit

Validation errors have been corrected on all three templates, including
removal of an extra </div>.

Revision: I was wrong about the frequency of use of "Modify." There's no
clear-cut reason to replace it with "Edit" so I have undone that change.

Signed-off-by: Frédéric Demians <f.demians@tamil.fr>
  Works as expected. No regression. Better texts. Consistent validation.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Brendan Gallagher 2016-03-03 22:31:43 UTC
Pushed to Master - Should be in the May 2016 release.  Thanks!
Comment 6 Julian Maurice 2016-03-07 13:06:45 UTC
Created attachment 48746 [details] [review]
[3.22.x] Bug 15925: Correct some markup issues with patron lists pages

Patch for 3.22.x
Comment 7 Julian Maurice 2016-03-07 13:06:58 UTC
Patch pushed to 3.22.x, will be in 3.22.5