Bug 16190 - Enable the indexer daemon by default
Summary: Enable the indexer daemon by default
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Keywords:
Depends on: 15113
Blocks: 16758 16823
  Show dependency treegraph
 
Reported: 2016-04-01 18:45 UTC by Tomás Cohen Arazi
Modified: 2017-12-07 22:15 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16190: Enable the indexer daemon by default (1.29 KB, patch)
2016-04-01 18:51 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 16190: Enable the indexer daemon by default (1.36 KB, patch)
2016-04-06 19:36 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16190: Enable the indexer daemon by default (1.42 KB, patch)
2016-04-07 11:52 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2016-04-01 18:45:41 UTC
The indexing daemon is a really cool feature, that there's no reason to have disabled by default. It allows end-users experience almost real-time indexing (with the default 5 seconds frecquency, which could even be lowered). And we have it disabled by default.

It prevents queuing too many reindexing actions, and has really low footprint (compared to the cronjob version).
Comment 1 Tomás Cohen Arazi 2016-04-01 18:51:33 UTC Comment hidden (obsolete)
Comment 2 Héctor Eduardo Castro Avalos 2016-04-06 19:36:25 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2016-04-07 11:52:37 UTC
Created attachment 50020 [details] [review]
Bug 16190: Enable the indexer daemon by default

This patch enables the indexer daemon by default on packages installs.
It does so by setting USE_INDEXER_DAEMON=yes on the /etc/default/koha-common
file. It does remove now irrelevant comments from that file.

This patch is straightforward to review. If is just a matter of choosing
to enable or not to enable by default.

Kind regards

PS: Let end users rejoice this so far hidden feature :-D

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 David Cook 2016-04-11 23:41:30 UTC
Yay! This makes me so happy ^_^.
Comment 5 Kyle M Hall 2016-04-29 14:09:14 UTC
It looks like these changes have already been made in master! Is this patch no longer needed?
Comment 6 Tomás Cohen Arazi 2016-04-29 14:39:10 UTC
This has already been pushed by Brendan on April 19th.

So will be available in 16.05 :-D
Comment 7 Magnus Enger 2016-06-27 12:39:38 UTC
See bug 16814 for some problems caused by the indexer daemon being on by default.