Bug 16200 - 'Hold waiting too long' fee has a translation problem
Summary: 'Hold waiting too long' fee has a translation problem
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
: 11387 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-05 09:21 UTC by Katrin Fischer
Modified: 2017-12-07 22:17 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16200: Make 'Hold waiting too long' translatable and give it an unique accounttype (3.92 KB, patch)
2016-05-17 13:36 UTC, Lari Taskula
Details | Diff | Splinter Review
Bug 16200: Convert all existing expired holds accounttype to HE (1.50 KB, patch)
2016-05-17 13:37 UTC, Lari Taskula
Details | Diff | Splinter Review
Bug 16200: Convert all existing expired holds accounttype to HE (1.52 KB, patch)
2016-05-17 14:18 UTC, Lari Taskula
Details | Diff | Splinter Review
Bug 16200: Make 'Hold waiting too long' translatable and give it an unique accounttype (3.98 KB, patch)
2016-05-18 09:09 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 16200: Convert all existing expired holds accounttype to HE (1.58 KB, patch)
2016-05-18 09:12 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
[PASSED QA] Bug 16200: Convert all existing expired holds accounttype to HE (1.65 KB, patch)
2016-05-18 22:30 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 16200: Make 'Hold waiting too long' translatable and give it an unique accounttype (4.05 KB, patch)
2016-05-19 21:38 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 16200: Convert all existing expired holds accounttype to HE (1.65 KB, patch)
2016-05-19 21:39 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2016-04-05 09:21:40 UTC
The fee entry for 'hold waiting too long' creates an accountlines entry containing untranslatable text and using an F fee type. It would be better to have use a unique fee type that can be used to show a translated entry in the GUI.

CancelReserve():
manualinvoice($reserve->{'borrowernumber'}, $reserve->{'itemnumber'}, 'Hold waiting too long', 'F', $charge);

Shows in the German GUI as:
Mahngebühr , Hold waiting too long 130251  Medium ansehen Physik in Demonstrationsversuchen.
Comment 1 Lari Taskula 2016-05-17 13:36:55 UTC Comment hidden (obsolete)
Comment 2 Lari Taskula 2016-05-17 13:37:49 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2016-05-17 13:39:18 UTC
Thx Lari!
Comment 4 Lari Taskula 2016-05-17 13:41:21 UTC
*** Bug 11387 has been marked as a duplicate of this bug. ***
Comment 5 Lari Taskula 2016-05-17 14:18:06 UTC Comment hidden (obsolete)
Comment 6 Olli-Antti Kivilahti 2016-05-18 09:09:32 UTC Comment hidden (obsolete)
Comment 7 Olli-Antti Kivilahti 2016-05-18 09:12:25 UTC Comment hidden (obsolete)
Comment 8 Katrin Fischer 2016-05-18 22:30:24 UTC Comment hidden (obsolete)
Comment 9 Lari Taskula 2016-05-19 09:44:14 UTC
What happened to the first patch "Bug 16200: Make 'Hold waiting too long' translatable and give it an unique accounttype"?
Comment 10 Katrin Fischer 2016-05-19 09:57:18 UTC
Ah, I am sorry. I missed the second patch when signing off and reattaching. Please feel free to fix - or I will do it tonight.
Comment 11 Katrin Fischer 2016-05-19 21:38:54 UTC
Created attachment 51631 [details] [review]
[PASSED QA] Bug 16200: Make 'Hold waiting too long' translatable and give it an unique accounttype

Holds that have expired have been untranslatable in Patron's Fines-tab. Also, they are
mixed with other type of fines with accounttype "F". This patch gives expired holds an
own accounttype "HE" (Hold Expired) and modifies the boraccount to recognize this new
accounttype in order to make it translatable.

To test:
1. Make a hold and let it expire
2. Go to Patron's Fines tab
3. Change Koha's language to some other than English
4. Observe that there is a "Hold waiting too long" fine described in English
5. Apply patch
6. Make another hold and let it expire
7. Update translations
8. Find "Hold waiting too long" from your .po file
9. Translate it and install translations
10. Go back to Fines tab and observe that the new expired hold is translated

Signed-off-by: Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 12 Katrin Fischer 2016-05-19 21:39:53 UTC
Created attachment 51632 [details] [review]
[PASSED QA] Bug 16200: Convert all existing expired holds accounttype to HE

Before Bug 16200 expired holds have used accounttype F which is also used by
other type of fines. This patch updates all existing expired holds to new
accounttype HE (Hold Expired).

To test:
-1. Make sure you translated the string in previous patch of this buug
1. Find a Patron with "Hold waiting too long" fines and go to his Fines tab
2. Change Koha's language to some other than English
3. Observe that "Hold waiting too long" is still in English
4. Apply patch and run database update
5. Go back to Patron's Fines tab
6. Observe that "Hold waiting too long" is now translated

Signed-off-by: Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 13 Brendan Gallagher 2016-05-31 09:15:12 UTC
Pushed to Master - Should be in the November Release.  Thanks!
Comment 14 Frédéric Demians 2016-06-15 07:30:37 UTC
Pushed in 16.05. Will be in 16.05.01.
Comment 15 Julian Maurice 2016-06-16 07:26:19 UTC
Patches pushed to 3.22.x, will be in 3.22.8