Bug 16303 - Koha::Logger appenders for interfaces 'commandline' and 'sip2'
Summary: Koha::Logger appenders for interfaces 'commandline' and 'sip2'
Status: RESOLVED DUPLICATE of bug 15253
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Olli-Antti Kivilahti
QA Contact: Testopia
URL:
Keywords:
Depends on: 14167
Blocks: 16312
  Show dependency treegraph
 
Reported: 2016-04-19 20:35 UTC by Olli-Antti Kivilahti
Modified: 2020-04-21 10:33 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16303 - Koha::Logger appenders for interfaces 'commandline' and 'sip2' (1.28 KB, patch)
2016-04-19 20:36 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 16303 - Koha::Logger appenders for interface 'commandline' (998 bytes, patch)
2016-04-20 13:14 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Olli-Antti Kivilahti 2016-04-19 20:35:00 UTC

    
Comment 1 Olli-Antti Kivilahti 2016-04-19 20:36:04 UTC
Created attachment 50441 [details] [review]
Bug 16303 - Koha::Logger appenders for interfaces 'commandline' and 'sip2'
Comment 2 Olli-Antti Kivilahti 2016-04-19 20:38:00 UTC
sip2 logging directed to a file instead of syslog.

When you have dozens of sip2-client in your koha-installation and want to redirect logging by library, you quickly run out of syslog faculties.
Comment 3 Kyle M Hall 2016-04-20 09:46:17 UTC
You may want to check out bug 15253
Comment 4 Olli-Antti Kivilahti 2016-04-20 13:14:32 UTC
Created attachment 50457 [details] [review]
Bug 16303 - Koha::Logger appenders for interface 'commandline'
Comment 5 Srdjan Jankovic 2016-06-01 02:42:16 UTC
The second file seems to be a repetition. Am I right?
Comment 6 Mark Tompsett 2016-06-02 03:08:00 UTC
(In reply to Srdjan Jankovic from comment #5)
> The second file seems to be a repetition. Am I right?

Yes, the smaller one seems like a partial duplicate of the larger one. Though, I think Kyle's comment #3 about bug 15253 seems like something that should be dealt with first in terms of interaction.
Comment 7 Katrin Fischer 2017-10-15 09:52:07 UTC
Choosing "Patch doesn't apply" over "In Discussion" here, but please read back and check what needs to be done!

Patches don't apply at the moment:

Applying: Bug 16303 - Koha::Logger appenders for interfaces 'commandline' and 'sip2'
Applying: Bug 16303 - Koha::Logger appenders for interface 'commandline'
fatal: sha1 information is lacking or useless (etc/log4perl.conf).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 16303 - Koha::Logger appenders for interface 'commandline'
The copy of the patch that failed is found in:
   /home/vagrant/kohaclone/.git/rebase-apply/patch
When you have resolved this problem run "git bz apply --continue".
If you would prefer to skip this patch, instead run "git bz apply --skip".
To restore the original branch and stop patching run "git bz apply --abort".
Patch left in /tmp/Bug-16303---KohaLogger-appenders-for-interface-com-GJ_gEX.patch
Comment 8 Jonathan Druart 2020-04-21 10:33:57 UTC
This will be fixed on bug 15253.

*** This bug has been marked as a duplicate of bug 15253 ***