Bug 16361 - Installer syntax error
Summary: Installer syntax error
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: master
Hardware: All All
: P1 - high critical (vote)
Target Milestone: Oldversions
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-27 02:00 UTC by Liz Rea
Modified: 2018-12-16 19:34 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16361: Installer syntax error (1.18 KB, patch)
2016-04-27 02:16 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 16361 - syntax error in updatedatabase (1.90 KB, patch)
2016-04-27 02:22 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 16361: Installer syntax error (1.24 KB, patch)
2016-04-27 02:26 UTC, Liz Rea
Details | Diff | Splinter Review
[PASSED QA] Bug 16361: Installer syntax error (1.31 KB, patch)
2016-04-27 08:21 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2016-04-27 02:00:47 UTC
This patch http://git.koha-community.org/gitweb/?p=koha.git;a=blobdiff;f=installer/data/mysql/updatedatabase.pl;h=1f1c5a0d60024e11037fb3aff38ee0ed45460d1f;hp=57c83db612be4d218e9d1fef85003db1dfa0ce24;hb=ee652b07cabe58ae10fb77f69488dbd1a74bf962;hpb=9b866b91affb4e96cf2bc0a3b66bb638ddc54986 seems to cause:

DBD::mysql::db do failed: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'ALTER TABLE edifact_messages ...
Comment 1 Bernardo Gonzalez Kriegel 2016-04-27 02:16:34 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2016-04-27 02:22:31 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2016-04-27 02:23:05 UTC
Comment on attachment 50780 [details] [review]
Bug 16361 - syntax error in updatedatabase

You beat me :)
Comment 4 Liz Rea 2016-04-27 02:26:16 UTC Comment hidden (obsolete)
Comment 5 Bernardo Gonzalez Kriegel 2016-04-27 02:37:54 UTC
(In reply to Liz Rea from comment #3)
> 
> You beat me :)

Yours was prettier :)
Comment 6 Liz Rea 2016-04-27 02:38:35 UTC
awww, hugs all around. :)
Comment 7 Liz Rea 2016-04-27 02:51:05 UTC
http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=4e6baf61858bd22d91d50ad5f176f04242a23370

With this patch we don't get this message, caused by the above patch:  

[Wed Apr 27 14:50:11 2016] updatedatabase.pl: Not a CODE reference at /home/liz/koha-src/koha/installer/data/mysql/updatedatabase.pl line 12355.
Comment 8 Bernardo Gonzalez Kriegel 2016-04-27 02:58:35 UTC
(In reply to Liz Rea from comment #7)
> http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;
> h=4e6baf61858bd22d91d50ad5f176f04242a23370
> 
> With this patch we don't get this message, caused by the above patch:  
> 
> [Wed Apr 27 14:50:11 2016] updatedatabase.pl: Not a CODE reference at
> /home/liz/koha-src/koha/installer/data/mysql/updatedatabase.pl line 12355.

Brendan beat us two, and it's pushed :)
Resolved -> Fixed?
Comment 9 Liz Rea 2016-04-27 02:59:13 UTC
Nope, his one is still broken. :(
Comment 10 Bernardo Gonzalez Kriegel 2016-04-27 03:06:44 UTC
(In reply to Liz Rea from comment #9)
> Nope, his one is still broken. :(

Yeap, a missing 'do'
Comment 11 Katrin Fischer 2016-04-27 08:21:15 UTC
Created attachment 50786 [details] [review]
[PASSED QA] Bug 16361: Installer syntax error

Bug 16354 introduces a syntax error on updatedatabase.pl
see comment #5 there

To test
1) Check error on update 3.23.00.051
2) Apply the patch
3) run updatedabase again (perhaps changing 051 to XXX)

Signed-off-by: Liz Rea <liz@catalyst.net.nz>
happy again!

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 12 Katrin Fischer 2016-04-27 08:21:37 UTC
Hi Brendan,

we are still missing a 'do' in the last updatedatabase entry:

-$dbh->(q{
+$dbh->do(q{


I have passed the patch here - so you can either fix it directly or revert the last commit and use this patch here.
Comment 13 Kyle M Hall 2016-04-27 12:57:30 UTC
Pushed to Master - Should be in the May 2016 Release.  Thanks!
Comment 14 Julian Maurice 2016-05-09 08:13:42 UTC
Not needed in stable versions, status changed to RESOLVED