Bug 16437 - Automatic item modifications by age needs prettying
Summary: Automatic item modifications by age needs prettying
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact: Testopia
URL: /cgi-bin/koha/tools/automatic_item_mo...
Whiteboard:
Keywords:
Depends on: 11023
Blocks: 18752
  Show dependency treegraph
 
Reported: 2016-05-03 19:34 UTC by Nicole C. Engard
Modified: 2018-06-04 20:10 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Medium patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16437 - Automatic item modifications by age needs prettying (25.79 KB, patch)
2016-05-05 14:04 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16437 - Automatic item modifications by age needs prettying (25.75 KB, patch)
2016-05-05 14:05 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16437 - Automatic item modifications by age needs prettying (25.89 KB, patch)
2016-05-05 14:53 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 16437 - Automatic item modifications by age needs prettying (25.96 KB, patch)
2016-05-20 14:41 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16437 - (follow-up) Automatic item modifications by age needs prettying (1.62 KB, patch)
2016-05-20 14:41 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2016-05-03 19:34:48 UTC
This page seems very confusing. There is no 'new' button, just edit and conditions and substitutions are confusing in terms of language. I think this page could do with the Owen magic touch :)
Comment 1 Owen Leonard 2016-05-05 14:04:27 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2016-05-05 14:05:57 UTC Comment hidden (obsolete)
Comment 3 Marc Véron 2016-05-05 14:53:34 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2016-05-06 14:30:33 UTC
1/ The age field is not mandatory
2/ The right member of the substitutions is not mandatory (you could empty it)
Comment 5 Jonathan Druart 2016-05-06 14:31:57 UTC
3/ "Remove condition/substitution" moves the scrollbar to the top
Comment 6 Jonathan Druart 2016-05-06 14:32:43 UTC
(In reply to Jonathan Druart from comment #5)
> 3/ "Remove condition/substitution" moves the scrollbar to the top

Also "Remove this rule"
Comment 7 Owen Leonard 2016-05-19 15:52:03 UTC
Jonathan could you check the issues you mention in comment 5 and comment 6 again? I cannot reproduce the problem. If they persist, are there JS errors?
Comment 8 Jonathan Druart 2016-05-20 14:40:01 UTC
(In reply to Owen Leonard from comment #7)
> Jonathan could you check the issues you mention in comment 5 and comment 6
> again? I cannot reproduce the problem. If they persist, are there JS errors?

Yes they persist and I do not get any JS errors.
Comment 9 Jonathan Druart 2016-05-20 14:41:35 UTC Comment hidden (obsolete)
Comment 10 Jonathan Druart 2016-05-20 14:41:38 UTC Comment hidden (obsolete)
Comment 11 Jonathan Druart 2016-05-20 14:41:56 UTC
(In reply to Jonathan Druart from comment #8)
> (In reply to Owen Leonard from comment #7)
> > Jonathan could you check the issues you mention in comment 5 and comment 6
> > again? I cannot reproduce the problem. If they persist, are there JS errors?
> 
> Yes they persist and I do not get any JS errors.

Ok fixed!
Comment 12 Brendan Gallagher 2016-05-31 14:16:49 UTC
Pushed to Master - Should be in the November 2016 Release. Thanks!
Comment 13 Frédéric Demians 2016-06-15 07:33:18 UTC
Pushed in 16.05. Will be in 16.05.01.
Comment 14 Jonathan Druart 2016-07-09 13:43:57 UTC
(In reply to Jonathan Druart from comment #4)
> 1/ The age field is not mandatory
> 2/ The right member of the substitutions is not mandatory (you could empty
> it)

I think that I have missed to check these 2 remarks before passing it.
The age field is not mandatory (and should not) as well as the substitutions.
Comment 15 Jonathan Druart 2017-06-07 18:31:35 UTC
(In reply to Jonathan Druart from comment #14)
> (In reply to Jonathan Druart from comment #4)
> > 1/ The age field is not mandatory
> > 2/ The right member of the substitutions is not mandatory (you could empty
> > it)
> 
> I think that I have missed to check these 2 remarks before passing it.
> The age field is not mandatory (and should not) as well as the substitutions.

See bug 18752.