Bug 16538 - Improve the style of progress bars
Summary: Improve the style of progress bars
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on: 16529
Blocks: 19674
  Show dependency treegraph
 
Reported: 2016-05-17 18:02 UTC by Owen Leonard
Modified: 2018-06-04 20:10 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Screenshot of a progress bar before the patch (17.49 KB, image/png)
2016-05-17 18:02 UTC, Owen Leonard
Details
Screenshot of a progress bar after the patch (19.62 KB, image/png)
2016-05-17 18:02 UTC, Owen Leonard
Details
Bug 16538 - Improve the style of progress bars (17.06 KB, patch)
2016-05-17 18:25 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16538 - Improve the style of progress bars (16.08 KB, patch)
2016-07-13 20:08 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 16538: Improve the style of progress bars (16.14 KB, patch)
2016-07-14 16:24 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16538: Improve the style of progress bars (16.18 KB, patch)
2016-07-15 14:09 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2016-05-17 18:02:24 UTC
Created attachment 51581 [details]
Screenshot of a progress bar before the patch

I would like to add some style to progress bars on various pages to make them  look a little nicer. See attached for before and after screenshots.
Comment 1 Owen Leonard 2016-05-17 18:02:48 UTC
Created attachment 51582 [details]
Screenshot of a progress bar after the patch
Comment 2 Owen Leonard 2016-05-17 18:25:40 UTC Comment hidden (obsolete)
Comment 3 Héctor Eduardo Castro Avalos 2016-06-24 20:32:26 UTC
Hi Owen

Applying: Bug 16538 - Improve the style of progress bars
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/tools/stage-marc-import.tt
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/tools/stage-marc-import.tt
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/tools/batchMod-edit.tt
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/tools/batchMod-del.tt
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/tools/batchMod-del.tt
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/offline_circ/process_koc.tt
Auto-merging koha-tmpl/intranet-tmpl/prog/css/staff-global.css
Failed to merge in the changes.
Comment 4 Mark Tompsett 2016-06-26 02:58:36 UTC
Conflicts caused by bug 16468 (added missing quote on ISO-8859-1 value as well as reformatted select) and bug 16602 (removed onclick and added id of same value as name attribute). I'll let Owen fix this as both those other bugs are Owen's as well, unless he comments otherwise.
Comment 5 Owen Leonard 2016-07-13 20:08:50 UTC Comment hidden (obsolete)
Comment 6 Héctor Eduardo Castro Avalos 2016-07-14 16:24:54 UTC Comment hidden (obsolete)
Comment 7 Héctor Eduardo Castro Avalos 2016-07-14 16:29:02 UTC
Just a comment: Would be great if Koha uses just one style of progress bar, right now I could see three styles
Comment 8 Jonathan Druart 2016-07-15 14:09:57 UTC
Created attachment 53436 [details] [review]
Bug 16538: Improve the style of progress bars

This patch updates the style of progress bars to make them a little
nicer. Progress bars in the staff client are not built in a consisten
way. Some have been updated to use the <progress> element and some have
not. This patch improves some styling common to both kinds.

Other changes:

- Redundant in-page CSS has been removed from many pages.
- An invalid "min" attribute has been removed from several instances of
  <progress>.
- Corrected capitalization.
- Fixed incorrectly quoted attributes.
- Added missing form "action" attributes.

To test, clear your browser cache if necessary. Apply the patch and
test uploads on the following pages:

- Circulation -> Offline circulation file upload
- Tools -> Batch item modification
- Tools -> Batch record modification
- Tools -> Stage MARC records for import
- Tools -> Manage staged MARC records
- Tools -> Upload local cover image
- Tools -> Upload

In all cases, progress bars should look improved and work correctly.

Test Tools -> Batch item deletion. Unused background job handling markup
has been removed. Deletion processing should work correctly.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 9 Kyle M Hall 2016-07-15 18:06:39 UTC
Pushed to master for 16.11, thanks Owen!
Comment 10 Frédéric Demians 2016-08-01 13:43:05 UTC
Pushed in 16.05. Will be in 16.05.02.