Bug 16540 - Translatability in opac-auth.tt (tag-splitted sentences)
Summary: Translatability in opac-auth.tt (tag-splitted sentences)
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Marc Véron
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-18 04:26 UTC by Marc Véron
Modified: 2017-12-07 22:16 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16540: Translatability in opac-auth.tt (tag-splitted sentences) (2.43 KB, patch)
2016-05-24 08:58 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 16540: Translatability in opac-auth.tt (tag-splitted sentences) (2.59 KB, patch)
2016-05-25 13:48 UTC, Marc Véron
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16540: Translatability in opac-auth.tt (tag-splitted sentences) (2.63 KB, patch)
2016-05-30 06:10 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
Bug 16540 - Clean up opac-auth.tt for translatability (16.97 KB, patch)
2016-06-01 14:56 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 16540 - Clean up opac-auth.tt for translatability (17.00 KB, patch)
2016-06-01 18:25 UTC, Marc Véron
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16540 - Clean up opac-auth.tt for translatability (17.10 KB, patch)
2016-06-01 19:07 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16540 - Clean up opac-auth.tt for translatability (17.12 KB, patch)
2016-06-07 15:18 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2016-05-18 04:26:47 UTC
In opac-auth.tt, the sentence 'Logout and try with a different user' is splitted by a-tags. It is difficult to determine the translation of the isolated word 'Logout' (e.g. in German: 'Abmeldung' or 'Abmelden' or 'Melden Sie sich ab')
Comment 1 Marc Véron 2016-05-22 06:49:32 UTC
Additional issue:
 <p>If you want to, you can try to <a href="/cgi-bin/koha/svc/auth/googleopenidconnect?reauthenticate=select_account">log in using a different account</a>
Comment 2 Marc Véron 2016-05-24 08:58:43 UTC Comment hidden (obsolete)
Comment 3 Marc Véron 2016-05-25 13:48:09 UTC Comment hidden (obsolete)
Comment 4 Srdjan Jankovic 2016-05-30 06:10:54 UTC Comment hidden (obsolete)
Comment 5 Marcel de Rooy 2016-05-31 10:59:09 UTC
Just a dumb question:
But don't we have other (easy) ways to achieve the same? Just hope so.
Now, we end up with large clickable texts (read: <a> tags)..
Comment 6 Marc Véron 2016-05-31 11:40:43 UTC
(In reply to Marcel de Rooy from comment #5)
> Just a dumb question:
> But don't we have other (easy) ways to achieve the same? Just hope so.
> Now, we end up with large clickable texts (read: <a> tags)..

I considered to have something like having an unlinked text as explanation followed by a link, something like:
"Logout and try again with a different user. <a..>Click here</>"
... but I do not think that that would be nicer.

Anyway, I agree with every solution that does not lead to messy / incorrect translations.
Comment 7 Marc Véron 2016-06-01 05:53:20 UTC
There are more issues, opac-auth.tt lines 90 and following.
Comment 8 Marc Véron 2016-06-01 14:44:02 UTC
I went through the file to locate more translation issues. The current indentation makes it difficult to read. That's why I'll try to clean up indentation as well. Otherwise it is difficult to be sure that changes do not have unwanted side effects.
Comment 9 Marc Véron 2016-06-01 14:56:58 UTC Comment hidden (obsolete)
Comment 10 Owen Leonard 2016-06-01 18:10:46 UTC
I see one typo:

"<p>If you have a CAS account, please please choose against which one you would like to authenticate:</p>"

There is an extra "please."

As long as we are making changes to this page, I have a couple of other suggestions:

- "Logout and try again with a different user" should use "Log out" instead.

- "If you have a Shibboleth account, please click here to login." should use "log in" instead of "login."

- "<p><a href="[% casServerUrl %]">Please click here to login.</a><p>" Use "log in" instead.

- "<p><a href="[% casServerUrl %]">If you have a CAS account, please click here to login.</a><p>" Use "log in" instead.

I looked for guidance for this on the terminology page on the wiki (https://wiki.koha-community.org/wiki/Terminology) and could not find it, but in my opinion it is analogous to this rule:

"Use 'checkout' as a noun, 'check out' as a verb."
Comment 11 Marc Véron 2016-06-01 18:25:28 UTC Comment hidden (obsolete)
Comment 12 Owen Leonard 2016-06-01 19:07:55 UTC Comment hidden (obsolete)
Comment 13 Jonathan Druart 2016-06-07 15:18:59 UTC
Created attachment 52154 [details] [review]
Bug 16540 - Clean up opac-auth.tt for translatability

This patch fixes translatability issues in opac-auth.tt (ugly
translations caused by sentence splitting).

It was necessary to change indentation to make the the file more
readable and to make sure that changes have no side effects.

The changes do not touch the overall functionallity.

To test:
- Review code to verify that no functionality change is introduced
  and to verify that the text changes make sense.
- Apply patch, verify that OPAC login page behaves as before.

UPDATE: Amended for comment #10 / mv
Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 14 Kyle M Hall 2016-06-10 17:45:26 UTC
Pushed to master for Koha 16.11, thanks Marc!
Comment 15 Frédéric Demians 2016-06-15 07:48:27 UTC
Pushed in 16.05. Will be in 16.05.01.
Comment 16 Julian Maurice 2016-06-16 09:55:22 UTC
Patch pushed to 3.22.x, will be in 3.22.8