Bug 16548 - All libraries selected on Tools -> Export Data screen
Summary: All libraries selected on Tools -> Export Data screen
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 16278 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-18 20:23 UTC by Joy Nelson
Modified: 2017-12-07 22:15 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16548 - All libraries selected on Tools -> Export Data screen (6.25 KB, patch)
2016-05-18 23:54 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16548 - All libraries selected on Tools -> Export Data screen (6.27 KB, patch)
2016-05-20 13:20 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 16548 - All libraries selected on Tools -> Export Data screen (6.38 KB, patch)
2016-05-26 11:34 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16548 - All libraries selected on Tools -> Export Data screen (6.42 KB, patch)
2016-05-26 11:55 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Joy Nelson 2016-05-18 20:23:59 UTC
In 3.22.05 when a user goes to the Tools->Export Data screen.  All the libraries are listed and checked.  This causes two issues:
1. In a large consortium a user may need to unclick a large number of boxes to only get the libraries they want.
2. When the tool is run as is (with all libraries selected) bibliographic records without items are not exported.  (ebook bib records without items)
Comment 1 Owen Leonard 2016-05-18 23:54:14 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2016-05-18 23:58:21 UTC
I suppose another good improvement would be to rename the library selection in such a way as to clarify that it limits based on items. "Export records with holdings from these libraries" or something like that?
Comment 3 Suzanne Fayle 2016-05-19 00:15:57 UTC
Or under options have a checkbox to include bibs without item records in the export? So that checking the box would export the bibs without items.

There is wording near the top "Note : The items are exported by this tool unless specified."
Comment 4 Nick Clemens 2016-05-20 13:20:53 UTC Comment hidden (obsolete)
Comment 5 Nick Clemens 2016-05-20 13:22:40 UTC
I think this is an excellent suggestion, but I think it is beyond the scope of this bug report (internal functionality vs display/user interface). 

Would you open a new bug for this Suzanne?

(In reply to Suzanne Fayle from comment #3)
> Or under options have a checkbox to include bibs without item records in the
> export? So that checking the box would export the bibs without items.
Comment 6 Jonathan Druart 2016-05-20 16:18:57 UTC
We usually use "Clear all" instead of "Select none", should not we stick to the existing wording?
Comment 7 Suzanne Fayle 2016-05-20 19:36:53 UTC
(In reply to Nick Clemens from comment #5)
> I think this is an excellent suggestion, but I think it is beyond the scope
> of this bug report (internal functionality vs display/user interface). 
> 
> Would you open a new bug for this Suzanne?
> 
> (In reply to Suzanne Fayle from comment #3)
> > Or under options have a checkbox to include bibs without item records in the
> > export? So that checking the box would export the bibs without items.

See Bug 16558. Thanks, Nick!
Comment 8 Owen Leonard 2016-05-26 11:34:01 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2016-05-26 11:55:26 UTC
Created attachment 51830 [details] [review]
Bug 16548 - All libraries selected on Tools -> Export Data screen

This patch adds "select all" and "select none" links to the display of
libraries in the export bibliographic records form.

Also modified: call number range and accession date fields have been
grouped in their own fieldsets in the hopes that this is more readable.
Page title and breadcrumbs have been corrected to read "Export data"
instead of "MARC export," matching menu items.

To test, apply the patch and go to Tools -> Export data.

- Test the select all/select none links and confirm that they work as
  expected.
- Confirm that the structural changes to the form look okay.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Post sign-off revision: Use the standard "Clear all" instead of "Select
none."

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 10 Brendan Gallagher 2016-05-30 11:18:04 UTC
Pushed to Master - Should be in the November 2016 release.  Thanks
Comment 11 Frédéric Demians 2016-06-15 07:29:28 UTC
Pushed in 16.05. Will be in 16.05.01.
Comment 12 Julian Maurice 2016-06-16 07:09:42 UTC
Patch pushed to 3.22.x, will be in 3.22.8
Comment 13 Nick Clemens 2016-07-05 18:04:51 UTC
*** Bug 16278 has been marked as a duplicate of this bug. ***