Bug 16655 - Date due error with SIP2 checkouts and holidays
Summary: Date due error with SIP2 checkouts and holidays
Status: RESOLVED DUPLICATE of bug 23640
Alias: None
Product: Koha
Classification: Unclassified
Component: SIP2 (show other bugs)
Version: 3.22
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-03 20:22 UTC by Humberto Blanco
Modified: 2019-12-05 12:33 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Humberto Blanco 2016-06-03 20:22:37 UTC
Hi, 
I created holidays for vacation period, if i borrow a book on staff inferface have no problems,but if so the same over SIP2 protocol do no take the holidays defined.

For example:
humberto blanco can borrow book for 8 days. If checkout from staff interface in 2016-06-03 has no problem and the date_due take all my holidays (2016-07-25); but if I do the same process over 3m selfcheck machine the date_due  is (2016-06-11)

Really appreciate your help to solve this issue

Humberto,
Comment 1 Katrin Fischer 2016-07-11 19:56:14 UTC
I am not sure if this will change something, but have you restarted the SIP server after adding the holidays? Does the problem still exist?
Comment 2 Magnus Enger 2019-12-05 08:42:51 UTC
I am also seeing this problem now, on 18.11.03: 
- Days around xmas are closed. 
- useDaysMode = Calculate the due date using [the calendar to push the due date to the next open day]

Loans issued through SIP2 sometimes get the unaltered 21 day loan time, with a return date on a date that is closed according to the calendar. Sometimes the loans get the proper return date, on the first day the library is open after the holidays.
Comment 3 Katrin Fischer 2019-12-05 09:20:22 UTC
Could this be bug 23640?
Comment 4 Magnus Enger 2019-12-05 09:34:13 UTC
(In reply to Katrin Fischer from comment #3)
> Could this be bug 23640?

Possibly. But it does seem strange that the wrong return dates are kind of random, sometimes it happens and sometimes it doesn't. And there is no pattern related to item types or patron categories, that I can see. 

I have restarted SIP2 and we will see what happens.
Comment 5 Magnus Enger 2019-12-05 12:33:45 UTC
Looks like a restart solved the problem. Marking this as a duplicate of bug 23640.

*** This bug has been marked as a duplicate of bug 23640 ***