Bug 16670 - CGI->param used in list context
Summary: CGI->param used in list context
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Keywords:
: 16646 16673 (view as bug list)
Depends on: 15823
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-06 12:20 UTC by Jonathan Druart
Modified: 2017-12-07 22:16 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16670: (bug 15823 follow-up) CGI->param should not be called in list context (1.03 KB, patch)
2016-06-06 12:32 UTC, Jonathan Druart
Details | Diff | Splinter Review
[3.22.x] Bug 16670: (bug 15823 follow-up) CGI->param should not be called in list context (1.21 KB, patch)
2016-06-06 12:36 UTC, Jonathan Druart
Details | Diff | Splinter Review
[3.22.x] Bug 16670: (bug 15823 follow-up) CGI->param should not be called in list context (1.26 KB, patch)
2016-06-06 15:53 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 16670: (bug 15823 follow-up) CGI->param should not be called in list context (1.09 KB, patch)
2016-06-06 16:53 UTC, Jacek Ablewicz
Details | Diff | Splinter Review
Bug 16670: (bug 15823 follow-up) CGI->param should not be called in list context (1.18 KB, patch)
2016-06-06 18:36 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-06-06 12:20:58 UTC

    
Comment 1 Jonathan Druart 2016-06-06 12:21:39 UTC
Introduced by bug 15823
Comment 2 Jonathan Druart 2016-06-06 12:32:02 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2016-06-06 12:32:06 UTC
*** Bug 16646 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Druart 2016-06-06 12:36:22 UTC Comment hidden (obsolete)
Comment 5 Jacek Ablewicz 2016-06-06 15:18:41 UTC
*** Bug 16673 has been marked as a duplicate of this bug. ***
Comment 6 Nick Clemens 2016-06-06 15:53:03 UTC
Created attachment 52089 [details] [review]
[3.22.x] Bug 16670: (bug 15823 follow-up) CGI->param should not be called in list context

This patch will remove the following warning "Staff members
are not allowed to discharge borrowers, nor borrowers to request a
discharge." in 3.22.x branches

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 7 Nick Clemens 2016-06-06 16:02:49 UTC
I can't recreate the issue on v16.05.00
Comment 8 Jacek Ablewicz 2016-06-06 16:53:00 UTC Comment hidden (obsolete)
Comment 9 Marcel de Rooy 2016-06-06 18:36:36 UTC
Created attachment 52093 [details] [review]
Bug 16670: (bug 15823 follow-up) CGI->param should not be called in list context

Signed-off-by: Jacek Ablewicz <abl@biblos.pk.edu.pl>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 10 Jonathan Druart 2016-06-06 19:15:19 UTC
(In reply to Nick Clemens from comment #7)
> I can't recreate the issue on v16.05.00

Because the param 'nopermission' is the last one passed through $template->param, but the problem might appear later.
Comment 11 Kyle M Hall 2016-06-17 14:36:24 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 12 Frédéric Demians 2016-06-24 05:44:47 UTC
Pushed in 16.05. Will be in 16.05.01.
Comment 13 Julian Maurice 2016-07-01 06:44:28 UTC
Patch pushed to 3.22.x, will be in 3.22.9