Bug 16675 - fix breakage of t/Languages.t
Summary: fix breakage of t/Languages.t
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Galen Charlton
URL:
Keywords:
Depends on: 16088
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-07 02:03 UTC by Galen Charlton
Modified: 2017-12-07 22:16 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16675: fix breakage of t/Languages.t (1.48 KB, patch)
2016-06-07 02:07 UTC, Galen Charlton
Details | Diff | Splinter Review
Bug 16675: fix breakage of t/Languages.t (1.64 KB, patch)
2016-06-07 12:55 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 16675: fix breakage of t/Languages.t (1.58 KB, patch)
2016-06-07 12:56 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 16675: fix breakage of t/Languages.t (1.61 KB, patch)
2016-06-07 15:58 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Galen Charlton 2016-06-07 02:03:57 UTC
The patch for bug 16088 introduces caching that breaks two tests in t/Languages.t. Upon inspection, it appears that the best resolution is to make the test cases explicitly clear the cache when needed.
Comment 1 Galen Charlton 2016-06-07 02:07:38 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2016-06-07 12:55:55 UTC Comment hidden (obsolete)
Comment 3 Marcel de Rooy 2016-06-07 12:56:38 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2016-06-07 15:58:27 UTC
Created attachment 52160 [details] [review]
Bug 16675: fix breakage of t/Languages.t

This patch fixes test breakage introduced by the patch for bug 16088,
which added caching of getlanguages().  Upon inspection, it looks like
the patch for 16088 does not introduce a regression on bug 10560,
so this patch adds a couple cache-clearings.

To test
-------
[1] Verify that t/Languages.t passes.

Signed-off-by: Galen Charlton <gmcharlt@gmail.com>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Kyle M Hall 2016-06-10 17:03:40 UTC
Pushed to master for 16.11, thanks Galen!
Comment 6 Frédéric Demians 2016-06-15 07:44:11 UTC
Pushed in 16.05. Will be in 16.05.01.
Comment 7 Julian Maurice 2016-06-16 09:05:13 UTC
Frédéric, you should probably push bug 16088 as well, because it introduce Koha::Cache::Memory::Lite (which is used by this patch)
Comment 8 Frédéric Demians 2016-06-16 10:51:57 UTC
(In reply to Julian Maurice from comment #7)
> Frédéric, you should probably push bug 16088 as well, because it introduce
> Koha::Cache::Memory::Lite (which is used by this patch)

I was reluctant to, but with a failing test, I have no choice. Thanks Julian.
Comment 9 Julian Maurice 2016-06-16 12:02:33 UTC
Patch pushed to 3.22.x, will be in 3.22.8
Comment 10 Jonathan Druart 2016-06-18 13:02:00 UTC
(In reply to Frédéric Demians from comment #8)
> (In reply to Julian Maurice from comment #7)
> > Frédéric, you should probably push bug 16088 as well, because it introduce
> > Koha::Cache::Memory::Lite (which is used by this patch)
> 
> I was reluctant to, but with a failing test, I have no choice. Thanks Julian.

I do not understand: this patch (16675) fixes a test which fails because of bug 16088.