Bug 16812 - Revise JS script for z3950_search.tts and remove onclick events
Summary: Revise JS script for z3950_search.tts and remove onclick events
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Héctor Eduardo Castro Avalos
QA Contact: Testopia
URL:
Keywords:
: 16811 (view as bug list)
Depends on: 16600
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-24 21:55 UTC by Héctor Eduardo Castro Avalos
Modified: 2017-12-07 22:16 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16812: Remove multiple onclick event from z3950_auth_search.tt (4.94 KB, patch)
2016-06-24 21:57 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16812: Remove multiple onclick events for all z3950_search.tt (20.98 KB, patch)
2016-06-25 05:37 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16812: Remove multiple onclick events for all z3950_search.tt (21.01 KB, patch)
2016-06-25 05:41 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16812: Remove multiple onclick events for all z3950_search.tt (21.01 KB, patch)
2016-06-25 05:42 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16812: Remove multiple onclick events for all z3950_search.tt (27.79 KB, patch)
2016-06-27 07:33 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16812: Revise JS script for z3950_search.tts and remove onclick events (28.05 KB, patch)
2016-06-27 07:49 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16812: Revise JS script for z3950_search.tts and remove onclick events (30.33 KB, patch)
2016-06-30 21:50 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16812: Revise JS script for z3950_search.tts and remove onclick events (30.34 KB, patch)
2016-06-30 21:58 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16812: Revise JS script for z3950_search.tts and remove onclick events (30.44 KB, patch)
2016-07-12 14:13 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 16812: Revise JS script for z3950_search.tts and remove onclick events (30.45 KB, patch)
2016-07-12 20:34 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Héctor Eduardo Castro Avalos 2016-06-24 21:55:21 UTC
z3950_auth_search.tt has various onclick events used in links.

This patch propose to triger event via JQuery .on()
Comment 1 Héctor Eduardo Castro Avalos 2016-06-24 21:57:32 UTC Comment hidden (obsolete)
Comment 2 Héctor Eduardo Castro Avalos 2016-06-25 05:37:08 UTC Comment hidden (obsolete)
Comment 3 Héctor Eduardo Castro Avalos 2016-06-25 05:41:15 UTC Comment hidden (obsolete)
Comment 4 Héctor Eduardo Castro Avalos 2016-06-25 05:42:25 UTC Comment hidden (obsolete)
Comment 5 Héctor Eduardo Castro Avalos 2016-06-27 07:33:40 UTC Comment hidden (obsolete)
Comment 6 Héctor Eduardo Castro Avalos 2016-06-27 07:49:43 UTC Comment hidden (obsolete)
Comment 7 Héctor Eduardo Castro Avalos 2016-06-29 20:52:20 UTC
*** Bug 16811 has been marked as a duplicate of this bug. ***
Comment 8 Héctor Eduardo Castro Avalos 2016-06-30 21:50:58 UTC Comment hidden (obsolete)
Comment 9 Héctor Eduardo Castro Avalos 2016-06-30 21:58:16 UTC Comment hidden (obsolete)
Comment 10 Owen Leonard 2016-07-12 14:13:01 UTC Comment hidden (obsolete)
Comment 11 Katrin Fischer 2016-07-12 20:34:26 UTC
Created attachment 53348 [details] [review]
[PASSED QA] Bug 16812: Revise JS script for z3950_search.tts and remove onclick events

Modify JS script to all templates for z3950_search.tt and reduce the
redundant code

This patch propose:
-z3950_auth_search.tt has various onclick events used in links.
 Also fix: acqui/z3950_search.tt and cataloguing/z3950_search.tt
-Trigger onclick events via JQuery .on()
-Make a separate .js and .inc file
-Reduce the number of line and redundant code
-Also add Font Awesome Icons to "Select/Clear all" and "Clear search
 form" links

To test:
1-Apply bug 16600 on top
2-Apply patch
3-Go to Authorities > click New from Z39.50
4-Fill some fields and click in "Clear search form" link
5-Search under "Dalton" or another author that launch too many headings
6-Clic in some heading and notice the dialog open, test: "Preview MARC",
  ISBD (when showed), "Import" and close the dialog "X". Use the
  "Import" from table too.
7-Use the "next/previous page" button, change "Go to page" to number in and
  out of the range presented, also test whit a letter, etc.

Go to Cataloging > New from Z39.50/SRU
Repeat steps 3 to 6. But this time with bib records.

Go to Adquisition > Open or Create a basket and choose to "Add to basket"
button. A modal appear, chose the option "Order from external source"
Repeat steps 3 to 6. But this thime with bib records.

NOTE: The icon trash for "Clear search form" has been selected according
with module "Advanced search" there is an icon trash with link "Clear
fields" that has the same fuctionality.
For some reason the image loading-small.gif does not charge all times
when the code is get out of the template. (Fixed with this new patch)
DataTable it is specific for each template

Sponsored-by: Universidad de El Salvador
Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 12 Kyle M Hall 2016-07-15 18:02:19 UTC
Pushed to master for 16.11, thanks Hector!
Comment 13 Frédéric Demians 2016-08-01 13:41:56 UTC
Pushed in 16.05. Will be in 16.05.02.