Bug 16904 - confirming hold throws mysql error
Summary: confirming hold throws mysql error
Status: RESOLVED DUPLICATE of bug 16942
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-12 15:28 UTC by Nicole C. Engard
Modified: 2016-07-19 17:16 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2016-07-12 15:28:28 UTC
I upgraded to master this morning and when I confirmed a hold after checking in an item I got the following error:

SQL::Abstract::puke(): [SQL::Abstract::__ANON__] Fatal: unexpected operator 'cancellationdate' with undef operand at /home/vagrant/kohaclone/Koha/Objects.pm line 168

I got it with two different items and a colleague got the same error on different data.
Comment 1 Mirko Tietgen 2016-07-18 09:55:46 UTC
I just found that too.

What I did is

- place holds on item
- check out item to someone else (override holds)
- check in item
- confirm hold

Same error as Nicole:

SQL::Abstract::puke(): [SQL::Abstract::__ANON__] Fatal: unexpected operator 'cancellationdate' with undef operand at /home/mirko/koha/Koha/Objects.pm line 168
Comment 2 Kyle M Hall 2016-07-19 17:16:17 UTC

*** This bug has been marked as a duplicate of bug 16942 ***