Bug 17013 - build-git-snapshot: add basetgz parameter and update master version number
Summary: build-git-snapshot: add basetgz parameter and update master version number
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Mirko Tietgen
QA Contact: Testopia
URL:
Keywords:
: 16676 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-01 15:17 UTC by Mirko Tietgen
Modified: 2016-08-13 11:50 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17013 - build-git-snapshot: add basetgz parameter and update master version number (1.67 KB, patch)
2016-08-01 15:19 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 17013 - build-git-snapshot: add basetgz parameter and update master version number (1.81 KB, patch)
2016-08-02 04:05 UTC, Frédéric Demians
Details | Diff | Splinter Review
[PASSED QA] Bug 17013 - build-git-snapshot: add basetgz parameter and update master version number (1.88 KB, patch)
2016-08-07 18:05 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2016-08-01 15:17:26 UTC
This adds a basetgz parameter to specify a pbuilder image. I use this to build against different distributions.

This also updates the version number for master builds to 16.06.
Comment 1 Mirko Tietgen 2016-08-01 15:19:19 UTC Comment hidden (obsolete)
Comment 2 Frédéric Demians 2016-08-02 04:05:22 UTC Comment hidden (obsolete)
Comment 3 Mirko Tietgen 2016-08-02 07:11:53 UTC
*** Bug 16676 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Druart 2016-08-02 10:46:34 UTC
Comment on attachment 53869 [details] [review]
Bug 17013 - build-git-snapshot: add basetgz parameter and update master version number

Review of attachment 53869 [details] [review]:
-----------------------------------------------------------------

::: debian/build-git-snapshot
@@ +31,4 @@
>  my $buildresult;
>  my $distribution='squeeze-dev';
>  my $git_checks='all';
> +my $version='16.06~git';

Should not we create a subroutine to guess the version?
Otherwise we will have to update it every 6 months :)
Comment 5 Mirko Tietgen 2016-08-02 11:53:24 UTC
(In reply to Jonathan Druart from comment #4)

> Should not we create a subroutine to guess the version?
> Otherwise we will have to update it every 6 months :)

I think we did something similar in some other place. Do you remember where?
Comment 6 Katrin Fischer 2016-08-02 21:44:53 UTC
Were you thinking about bug 16724?
Comment 7 Katrin Fischer 2016-08-07 17:45:01 UTC
Waiting for feedback from Mirko.
Comment 8 Mirko Tietgen 2016-08-07 17:55:07 UTC
Katrin: You're right, but it does not really appy here. Also I override the version anyway. I think changing this to a more intelligent setting should be a seperate patch, I need the basetgz part now.
Comment 9 Katrin Fischer 2016-08-07 18:04:37 UTC
Trusting Mirko here.
Comment 10 Katrin Fischer 2016-08-07 18:05:49 UTC
Created attachment 54125 [details] [review]
[PASSED QA] Bug 17013 - build-git-snapshot: add basetgz parameter and update master version number

This adds a basetgz parameter to specify a pbuilder image.
I use this to build against different distributions.

This also updates the version number for master builds to 16.06.

Signed-off-by: Frédéric Demians <f.demians@tamil.fr>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 11 Kyle M Hall 2016-08-08 13:14:15 UTC
Pushed to master for 16.11, thanks Mirko!
Comment 12 Mirko Tietgen 2016-08-08 13:37:15 UTC
Thanks Kyle!

Frederic: Can you push this to 16.05 please? I need it for the nightly builds.
Comment 13 Frédéric Demians 2016-08-08 14:34:50 UTC
Pushed in 16.05. Will be in 16.05.03.