Bug 17043 - debian/list-deps fixes, master edition
Summary: debian/list-deps fixes, master edition
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
: 16643 (view as bug list)
Depends on:
Blocks: 16643 17062
  Show dependency treegraph
 
Reported: 2016-08-03 17:16 UTC by Mirko Tietgen
Modified: 2018-05-30 10:29 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17043 - debian/list-deps fixes, master edition (1.28 KB, patch)
2016-08-03 17:45 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 17043 - Readonly deps (868 bytes, patch)
2016-08-03 17:45 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 17043 - master control file (4.18 KB, patch)
2016-08-03 17:46 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 17043 - Readonly deps (908 bytes, patch)
2016-08-04 22:21 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 17043 - Readonly deps (887 bytes, patch)
2016-08-04 22:51 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 17043 - debian/list-deps fixes, master edition (1.34 KB, patch)
2016-08-08 14:18 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 17043 - master control file (4.18 KB, patch)
2016-08-08 14:18 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 17043 - Readonly deps (942 bytes, patch)
2016-08-08 14:18 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 17043 - debian/list-deps fixes, 16.05 edition (981 bytes, patch)
2016-08-09 16:18 UTC, Mirko Tietgen
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2016-08-03 17:16:05 UTC
This makes debian/list-deps ready for Debian Jessie and adds small fixes I already use for package releases.
Comment 1 Mirko Tietgen 2016-08-03 17:45:55 UTC Comment hidden (obsolete)
Comment 2 Mirko Tietgen 2016-08-03 17:45:57 UTC Comment hidden (obsolete)
Comment 3 Mirko Tietgen 2016-08-03 17:46:00 UTC Comment hidden (obsolete)
Comment 4 Mirko Tietgen 2016-08-04 22:21:20 UTC Comment hidden (obsolete)
Comment 5 Mirko Tietgen 2016-08-04 22:51:47 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2016-08-08 09:26:49 UTC
(In reply to Mirko Tietgen from comment #5)
> Created attachment 54015 [details] [review] [review]
> Bug 17043 - Readonly deps

Mirko, actually bug 16588 removes this dependency.
Comment 7 Mirko Tietgen 2016-08-08 09:51:53 UTC
(In reply to Jonathan Druart from comment #6)
> (In reply to Mirko Tietgen from comment #5)
> > Created attachment 54015 [details] [review] [review] [review]
> > Bug 17043 - Readonly deps
> 
> Mirko, actually bug 16588 removes this dependency.

I know. That is why it is a seperate patch here. Until 16588 is in, I need this patch for the nightly packages. I apply this and some other patches before I build them. I will obsolete that part when the other bug is pushed.
Comment 8 Tomás Cohen Arazi 2016-08-08 14:18:09 UTC
Created attachment 54168 [details] [review]
Bug 17043 - debian/list-deps fixes, master edition

This makes debian/list-deps ready for Debian Jessie
and adds small fixes I already use for package releases.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 9 Tomás Cohen Arazi 2016-08-08 14:18:16 UTC
Created attachment 54169 [details] [review]
Bug 17043 - master control file

latest control file update

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 10 Tomás Cohen Arazi 2016-08-08 14:18:21 UTC
Created attachment 54170 [details] [review]
Bug 17043 - Readonly deps

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 11 Kyle M Hall 2016-08-08 14:27:43 UTC
Pushed to master for 16.11, thanks Mirko!
Comment 12 Frédéric Demians 2016-08-08 14:49:00 UTC
Is it also targeted to 16.05?
Comment 13 Mirko Tietgen 2016-08-08 21:59:53 UTC
(In reply to Frédéric Demians from comment #12)
> Is it also targeted to 16.05?

The first one should go in 16.05 if it applies (I will check), the second one is not needed, I will check about the third.
Comment 14 Mirko Tietgen 2016-08-09 15:50:03 UTC
Actually there is a nicer regex from the hackfest in greece at bug 16643.
Comment 15 Mirko Tietgen 2016-08-09 16:18:05 UTC
Created attachment 54228 [details] [review]
Bug 17043 - debian/list-deps fixes, 16.05 edition

This makes debian/list-deps ready for Debian Jessie
and adds small fixes I already use for package releases.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 16 Mirko Tietgen 2016-08-09 16:20:21 UTC
Frederic: Above this is the first patch for 16.05. 16643 applies on top of it, if you want to take that too. It's just a smaller regex and examples, but has not been signed off yet.
Comment 17 Mirko Tietgen 2016-08-09 16:24:00 UTC
Frederic: The third patch (Bug 17043 - Readonly deps) applies to 16.05.x and should go in there. I will update the control file when it is pushed.
Comment 18 Frédéric Demians 2016-08-10 07:01:26 UTC
Thanks Mirko. I've picked patches 3 & 4.
Comment 19 Mirko Tietgen 2018-05-30 10:29:38 UTC
*** Bug 16643 has been marked as a duplicate of this bug. ***