Bug 17074 - Fix links in result list of 'scan indexes' search and keep search term
Summary: Fix links in result list of 'scan indexes' search and keep search term
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Katrin Fischer
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-07 14:01 UTC by Katrin Fischer
Modified: 2017-12-07 22:16 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17074: Fix links in result list of 'scan indexes' and keep search term visible (3.76 KB, patch)
2016-08-07 14:07 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 17028: Follow-up: fixing encoding issues with multiple search terms (2.08 KB, patch)
2016-08-07 23:17 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 17074: Fix links in result list of 'scan indexes' and keep search term visible (3.76 KB, patch)
2016-08-07 23:19 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 17074: Follow-up: fixing encoding issues with multiple search terms (2.08 KB, patch)
2016-08-07 23:20 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 17074: Fix links in result list of 'scan indexes' and keep search term visible (3.84 KB, patch)
2016-08-08 06:51 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 17074: Follow-up: fixing encoding issues with multiple search terms (2.11 KB, patch)
2016-08-08 06:52 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 17074: Fix links in result list of 'scan indexes' and keep search term visible (3.92 KB, patch)
2016-08-09 09:44 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17074: Follow-up: fixing encoding issues with multiple search terms (2.18 KB, patch)
2016-08-09 09:44 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2016-08-07 14:01:49 UTC
The 'scan indexes' search that can be reached from the advanced search has 2 problems to begin with:

- The search term you searched for is not displayed in the input field.
- The links in the result list are missing the index and because of that, are not giving the correct results.
Comment 1 Katrin Fischer 2016-08-07 14:07:18 UTC Comment hidden (obsolete)
Comment 2 Christopher Brannon 2016-08-07 22:35:28 UTC
(In reply to Katrin Fischer from comment #1)
> Created attachment 54123 [details] [review] [review]
> Bug 17074: Fix links in result list of 'scan indexes' and keep search term
> visible
> 
> The 'scan indexes' search that can be reached from the
> advanced search has 2 problems to begin with:
> 
> - The search term you searched for is not displayed
>   in the input field.
> - The links in the result list are missing the index
>   and because of that, are not giving the correct results.
> 
> To test:
> - Go to the advanced search, select an index to search in
> - Enter a search term and check 'scan indexes'
> - Submit search
> - Check if the search term is visible in the input box
> - Check if the result links contain your selected index
>   and give you correct results (count and the number of
>   results should match)

Katrin,
I would like to sign off on this, but as far as I can tell, the patch only addresses the links.  I can't confirm an issue with the counts, most likely because of the limited number of records I have at the moment, so for that, someone else should test at this time.  Also, I see no change with the search term in the input box, unless I am looking at the wrong thing.  To me, on this page, the input box should be the textbox labeled "Scan Index for:".  If this is the case, the box is still blank, and therefore does not pass your test plan.  Please clarify.  Thank you.
Comment 3 Katrin Fischer 2016-08-07 22:44:12 UTC
I am not sure what it could be, it works for me. Can please someone else take another look to get a better picture?

The counts are correct, the problem is when you click on the link and it's missing the index to search in - so it does a keyword search.

So say you did a search for Author, then the counts will show the counts in the author index, but the link would start a keyword search which is likely to give you a different number of results.

Best to test this not using the 'keyword' option
Comment 4 Katrin Fischer 2016-08-07 22:51:32 UTC
Christopher, I tried various searches - the "Scan Index for:" is always set for me with the patch applied. I tried different indexes. I would be interested to see your link to the page when it doesn't work. Also, could you check the patch applied nicely?
Comment 5 Katrin Fischer 2016-08-07 22:55:02 UTC
Hm, just found a little problem - if you enter 2 search terms, you will see something like: all%20this - url encoded... I have to check on how to fix this.
Comment 6 Katrin Fischer 2016-08-07 23:17:13 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2016-08-07 23:19:54 UTC Comment hidden (obsolete)
Comment 8 Katrin Fischer 2016-08-07 23:20:24 UTC Comment hidden (obsolete)
Comment 9 Marc Véron 2016-08-08 06:51:09 UTC Comment hidden (obsolete)
Comment 10 Marc Véron 2016-08-08 06:52:07 UTC Comment hidden (obsolete)
Comment 11 Jonathan Druart 2016-08-09 09:44:04 UTC
Created attachment 54190 [details] [review]
Bug 17074: Fix links in result list of 'scan indexes' and keep search term visible

The 'scan indexes' search that can be reached from the
advanced search has 2 problems to begin with:

- The search term you searched for is not displayed
  in the input field.
- The links in the result list are missing the index
  and because of that, are not giving the correct results.

To test:
- Go to the advanced search, select an index to search in
- Enter a search term and check 'scan indexes'
- Submit search
- Check if the search term is visible in the input box
- Check if the result links contain your selected index
  and give you correct results (count and the number of
  results should match)

Tested both patches together, works as expected.
Signed-off-by: Marc <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 12 Jonathan Druart 2016-08-09 09:44:07 UTC
Created attachment 54191 [details] [review]
Bug 17074: Follow-up: fixing encoding issues with multiple search terms

If there was more than one search term you could see that that it
was url encoded. Also problems with search terms with umlauts and
other diacritics.

Patch should fix that.

https://bugs.koha-community.org/show_bug.cgi?id=17074
Signed-off-by: Marc <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 13 Kyle M Hall 2016-08-10 13:38:55 UTC
Pushed to master for 16.11, thanks Katrin!
Comment 14 Frédéric Demians 2016-08-23 09:41:53 UTC
Pushed in 16.05. Will be in 16.05.03.
Comment 15 Julian Maurice 2016-08-23 15:34:51 UTC
Pushed to 3.22.x, will be in 3.22.10