Bug 17300 - Serials search does not return any results
Summary: Serials search does not return any results
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 16157
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-14 13:41 UTC by Jonathan Druart
Modified: 2017-12-07 22:16 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17300: Fix serials search (1.23 KB, patch)
2016-09-14 13:42 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17300: Fix serials search (1.37 KB, patch)
2016-09-14 14:03 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 17300: Fix serials search (1.45 KB, patch)
2016-09-14 14:07 UTC, Andreas Roussos
Details | Diff | Splinter Review
[PASSED QA] Bug 17300: Fix serials search (1.52 KB, patch)
2016-09-18 10:09 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-09-14 13:41:09 UTC
Since bug 16157, the location value is always "All" and the serial search won't return anything.
Comment 1 Jonathan Druart 2016-09-14 13:42:24 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2016-09-14 14:03:14 UTC Comment hidden (obsolete)
Comment 3 Andreas Roussos 2016-09-14 14:07:53 UTC
Created attachment 55566 [details] [review]
Bug 17300: Fix serials search

Since bug 16157, the location value is always "All" and the serial
search won't return anything.

Test plan:
Search for some serials.
Without this patch, it won't return any results
With this patch applied, the result search should be consistent

Reproduced with serial's "Advanced search" and search filter in
left hand column. Fixed by this patch.
Signed-off-by: Marc <veron@veron.ch>

Advanced search works fine again.
Signed-off-by: Andreas Roussos <arouss1980@gmail.com>
Comment 4 Katrin Fischer 2016-09-18 10:09:33 UTC
Created attachment 55644 [details] [review]
[PASSED QA] Bug 17300: Fix serials search

Since bug 16157, the location value is always "All" and the serial
search won't return anything.

Test plan:
Search for some serials.
Without this patch, it won't return any results
With this patch applied, the result search should be consistent

Reproduced with serial's "Advanced search" and search filter in
left hand column. Fixed by this patch.
Signed-off-by: Marc <veron@veron.ch>

Advanced search works fine again.
Signed-off-by: Andreas Roussos <arouss1980@gmail.com>

Signed-off-by: Katrin Fischer  <katrin.fischer@bsz-bw.de>
Comment 5 Kyle M Hall 2016-09-27 11:10:11 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 6 Frédéric Demians 2016-09-30 08:40:47 UTC
Pushed in 16.05. Will be in 16.05.05.