Bug 17535 - Regression: Search for reports by keywords
Summary: Regression: Search for reports by keywords
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 14435
Blocks: 22357
  Show dependency treegraph
 
Reported: 2016-11-02 09:36 UTC by Jonathan Druart
Modified: 2019-04-09 11:22 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17535: Fix search for reports by keywords (1.52 KB, patch)
2016-11-02 09:39 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 17535: Fix search for reports by keywords (1.58 KB, patch)
2016-11-02 15:10 UTC, Josef Moravec
Details | Diff | Splinter Review
[PASSED QA] Bug 17535: Fix search for reports by keywords (1.64 KB, patch)
2016-11-06 10:10 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-11-02 09:36:45 UTC
Introduced by bug 14435
Comment 1 Jonathan Druart 2016-11-02 09:39:49 UTC
Created attachment 57069 [details] [review]
Bug 17535: Fix search for reports by keywords

The commit cf9031711282f4be23e4a639797d0fd178940e1f
    Bug 14435: Add the ability to store result's report
introduced a regression when searching for reports by keywords.
It also breaks tests in t/db_dependent/Reports/Guided.t

It's caused by the missing join on saved_reports.
The error says DBD::mysql::db selectall_arrayref failed: Unknown column
'report' in 'where clause'

Test plan:
Confirm that the tests are fixed and that you are able to search for
reports using the "keyword" input
Comment 2 Josef Moravec 2016-11-02 15:10:33 UTC
Created attachment 57106 [details] [review]
[SIGNED-OFF] Bug 17535: Fix search for reports by keywords

The commit cf9031711282f4be23e4a639797d0fd178940e1f
    Bug 14435: Add the ability to store result's report
introduced a regression when searching for reports by keywords.
It also breaks tests in t/db_dependent/Reports/Guided.t

It's caused by the missing join on saved_reports.
The error says DBD::mysql::db selectall_arrayref failed: Unknown column
'report' in 'where clause'

Test plan:
Confirm that the tests are fixed and that you are able to search for
reports using the "keyword" input

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 3 Katrin Fischer 2016-11-06 10:10:46 UTC
Created attachment 57229 [details] [review]
[PASSED QA] Bug 17535: Fix search for reports by keywords

The commit cf9031711282f4be23e4a639797d0fd178940e1f
    Bug 14435: Add the ability to store result's report
introduced a regression when searching for reports by keywords.
It also breaks tests in t/db_dependent/Reports/Guided.t

It's caused by the missing join on saved_reports.
The error says DBD::mysql::db selectall_arrayref failed: Unknown column
'report' in 'where clause'

Test plan:
Confirm that the tests are fixed and that you are able to search for
reports using the "keyword" input

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Katrin Fischer  <katrin.fischer@bsz-bw.de>
Comment 4 Kyle M Hall 2016-11-07 16:38:34 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 5 Mason James 2016-12-14 10:09:02 UTC
Blocked by enhancement, skipping for 16.05.x