Bug 17546 - Importing records with a matching rules fails when using Elastic
Summary: Importing records with a matching rules fails when using Elastic
Status: RESOLVED DUPLICATE of bug 18131
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-03 14:42 UTC by Kyle M Hall
Modified: 2017-04-03 18:28 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2016-11-03 14:42:04 UTC
If the system preference SearchEngine is set to Elasticsearch, attempting to use matching rules fails with the error:

Can't locate object method "fields" via package "MARC::Record=HASH(0x9ce46a8)" (perhaps you forgot to load "MARC::Record=HASH(0x9ce46a8)"?) at /home/vagrant/kohaclone/C4/Biblio.pm line 2713.

It appears that the contents of the variable assumed to be a MARC::Record object are literally a string and not eh object. I was able to narrow down the issue to something going on in C4::Matcher::get_matches.
Comment 1 Nick Clemens 2017-04-03 18:28:14 UTC

*** This bug has been marked as a duplicate of bug 18131 ***