Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610
Summary: Regression: Incomplete CSS update introduced by Bug 14610
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on: 14610
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-09 18:20 UTC by Owen Leonard
Modified: 2018-06-04 20:10 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610 (4.31 KB, patch)
2016-11-10 10:51 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610 (4.37 KB, patch)
2016-11-12 20:07 UTC, Chris Kirby
Details | Diff | Splinter Review
Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610 (4.37 KB, patch)
2016-11-18 07:05 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610 (4.44 KB, patch)
2016-11-18 07:08 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2016-11-09 18:20:27 UTC
Bug 14610 revised staff-global.css so that the "holdcount" class was renamed "number_box." That's good. It's good to have something more generic since the class is used in multiple places.

The problem is that there are still several instances of the "holdcount" class in the templates which should have been updated at the same time to say "number_box." Those instances are now unstyled.
Comment 1 Kyle M Hall 2016-11-10 10:51:47 UTC
Created attachment 57422 [details] [review]
Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610

Bug 14610 revised staff-global.css so that the "holdcount" class was
renamed "number_box." That's good. It's good to have something more
generic since the class is used in multiple places.

The problem is that there are still several instances of the "holdcount"
class in the templates which should have been updated at the same time
to say "number_box." Those instances are now unstyled.

Test Plan:
1) Apply this patch
2) Check that the holds count on catalogue/detail.pl is styled
3) Check that the patron modifications count on members/member.pl is styled
4) Check that the pending comments count on tools/tools-home.pl is styled
5) Check that the pending tags count on tools/tools-home.pl is styled
Comment 2 Chris Kirby 2016-11-10 19:35:45 UTC
So far, I am finding that the templates have indeed updated so that the "holdcount" class has been replaced by "number_box." But pending comments count on tools/tools-home.pl and also (the other instances) does have a border around the number or a background-color, whereas "holdcount" did. Is this what is expected?
Comment 3 Chris Kirby 2016-11-10 19:39:48 UTC
(In reply to Chris Kirby from comment #2)
> So far, I am finding that the templates have indeed updated so that the
> "holdcount" class has been replaced by "number_box." But pending comments
> count on tools/tools-home.pl (and also the other instances) does have a
> border around the number or a background-color, whereas "holdcount" did. Is
> this what is expected?
Comment 4 Chris Kirby 2016-11-11 18:00:12 UTC
1)Applied patch in  this patch in a sandbox (http://pro.user10-koha.sandbox.biblibre.eu/). I also tested the existing behavior on master in 
(http://pro.user09-koha.sandbox.biblibre.eu/).
 
Created a hold on an item, signed into the OPAC as a patron and modified patron information; in the OPAC added a tag to a title. in the OPAC, added a comment to a title. 

In the staff client, I checked the following: 
2)Checked that the holds count on catalogue/detail.pl. It has been renamed "number_box" but does not appear to be styled.
3) Check that the patron modifications count on members/member.pl. It has been renamed "number_box" but does not appear to be styled.
4) Check that the pending comments count on tools/tools-home.pl. It has been renamed "number_box" but does not appear to be styled.
5) Check that the pending tags count on tools/tools-home.pl. It has been renamed "number_box" but does not appear to be styled.
Comment 5 Chris Kirby 2016-11-12 20:07:55 UTC
Created attachment 57466 [details] [review]
Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610

Bug 14610 revised staff-global.css so that the "holdcount" class was
renamed "number_box." That's good. It's good to have something more
generic since the class is used in multiple places.

The problem is that there are still several instances of the "holdcount"
class in the templates which should have been updated at the same time
to say "number_box." Those instances are now unstyled.

Test Plan:
1) Apply this patch
2) Check that the holds count on catalogue/detail.pl is styled
3) Check that the patron modifications count on members/member.pl is styled
4) Check that the pending comments count on tools/tools-home.pl is styled
5) Check that the pending tags count on tools/tools-home.pl is styled

Signed-off-by: Chris Kirby <christopherlawrencekirby@gmail.com>
Comment 6 Chris Kirby 2016-11-12 20:17:13 UTC
Signed off (comment 5) after applying patch to my local development environment and observing the expected styling.
Comment 7 Katrin Fischer 2016-11-18 07:05:49 UTC
Created attachment 57611 [details] [review]
Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610

Bug 14610 revised staff-global.css so that the "holdcount" class was
renamed "number_box." That's good. It's good to have something more
generic since the class is used in multiple places.

The problem is that there are still several instances of the "holdcount"
class in the templates which should have been updated at the same time
to say "number_box." Those instances are now unstyled.

Test Plan:
1) Apply this patch
2) Check that the holds count on catalogue/detail.pl is styled
3) Check that the patron modifications count on members/member.pl is styled
4) Check that the pending comments count on tools/tools-home.pl is styled
5) Check that the pending tags count on tools/tools-home.pl is styled

Signed-off-by: Chris Kirby <christopherlawrencekirby@gmail.com>
Comment 8 Katrin Fischer 2016-11-18 07:08:19 UTC
Created attachment 57612 [details] [review]
[PASSED QA] Bug 17601 - Regression: Incomplete CSS update introduced by Bug 14610

Bug 14610 revised staff-global.css so that the "holdcount" class was
renamed "number_box." That's good. It's good to have something more
generic since the class is used in multiple places.

The problem is that there are still several instances of the "holdcount"
class in the templates which should have been updated at the same time
to say "number_box." Those instances are now unstyled.

Test Plan:
1) Apply this patch
2) Check that the holds count on catalogue/detail.pl is styled
3) Check that the patron modifications count on members/member.pl is styled
4) Check that the pending comments count on tools/tools-home.pl is styled
5) Check that the pending tags count on tools/tools-home.pl is styled

Signed-off-by: Chris Kirby <christopherlawrencekirby@gmail.com>

Signed-off-by: Katrin Fischer  <katrin.fischer@bsz-bw.de>
Comment 9 Kyle M Hall 2016-11-18 14:15:42 UTC
Pushed to master for 16.11!
Comment 10 Mason James 2016-12-14 11:30:48 UTC
Blocked by new feature, skipping for 16.05.x