Bug 17727 - A lot of tests fail if SearchEngine is set to Elastic
Summary: A lot of tests fail if SearchEngine is set to Elastic
Status: RESOLVED DUPLICATE of bug 17726
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 12478
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-06 09:55 UTC by Jonathan Druart
Modified: 2016-12-13 11:56 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-12-06 09:55:32 UTC
The items.more_subfields_xml is set to random data (generated by TestBuilder), and so GetMarcBiblio does not manage to embed items (if needed).

The error is:
  :1: parser error : Start tag expected, '<' not found

More precisely it explodes in C4::Items::_parse_unlinked_item_subfields_from_xml when MARC::Record->new_from_xml is called with an invalid xml
Comment 1 Jonathan Druart 2016-12-06 09:57:21 UTC
I'd recomend to add a default value (undef/NULL) for items.more_subfields_xml in TestBuilder, not to modify everywhere we build a new item.
Comment 2 Jonathan Druart 2016-12-13 11:56:11 UTC
Will be fixed by bug 17726.

*** This bug has been marked as a duplicate of bug 17726 ***