Bug 18136 - Content of ExportRemoveFields is not picked to pre-fill field list
Summary: Content of ExportRemoveFields is not picked to pre-fill field list
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
Depends on: 13190
Blocks: 15498
  Show dependency treegraph
 
Reported: 2017-02-17 09:55 UTC by Jonathan Druart
Modified: 2017-06-14 22:17 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18136: Fix ExportRemoveFields pre-fill behaviour (1.84 KB, patch)
2017-02-17 10:02 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18136: Fix ExportRemoveFields pre-fill behaviour (1.94 KB, patch)
2017-02-17 11:02 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2017-02-17 09:55:14 UTC

    
Comment 1 Jonathan Druart 2017-02-17 09:56:11 UTC
Looks like it's caused by bug 13190.
Comment 2 Jonathan Druart 2017-02-17 10:02:36 UTC
Created attachment 60384 [details] [review]
Bug 18136: Fix ExportRemoveFields pre-fill behaviour

Looks like it's caused by bug 13190.
Variable export_remove_fields is not sent to the template, let's
retrieve the syspref's value using the TT plugin.

Test plan:
Fill ExportRemoveFields with something (100a for instance)
Go on a checkout list page
At the bottom, the "do not export fields" input box should be pre-filled
with the content of the syspref
Comment 3 Marcel de Rooy 2017-02-17 11:02:23 UTC
Created attachment 60397 [details] [review]
Bug 18136: Fix ExportRemoveFields pre-fill behaviour

Looks like it's caused by bug 13190.
Variable export_remove_fields is not sent to the template, let's
retrieve the syspref's value using the TT plugin.

Test plan:
Fill ExportRemoveFields with something (100a for instance)
Go on a checkout list page
At the bottom, the "do not export fields" input box should be pre-filled
with the content of the syspref

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 4 Marcel de Rooy 2017-02-17 11:03:55 UTC
Passing QA now too. This should definitely not wait 4 months :)
Kyle: Push it now !
Comment 5 Kyle M Hall 2017-02-17 11:25:29 UTC
Pushed to master for 17.05, thanks Jonathan!
Comment 6 Katrin Fischer 2017-02-19 20:03:03 UTC
This patch has been pushed to 16.11.x and will be in 16.11.04.
Comment 7 Julian Maurice 2017-02-20 10:38:39 UTC
Pushed to 3.22.x for 3.22.17
Comment 8 Mason James 2017-02-22 23:15:42 UTC
Pushed to 16.05.x, for 16.05.10 release