Bug 18210 - Allow API to update/ merge bibliographic records & not just replace
Summary: Allow API to update/ merge bibliographic records & not just replace
Status: RESOLVED DUPLICATE of bug 14957
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-04 12:43 UTC by Cab Vinton
Modified: 2020-01-11 23:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cab Vinton 2017-03-04 12:43:53 UTC
The Koha API allows for existing records to be replaced/ overlaid wholesale with data  provided.

It would be great to have the option of updating records as well, i.e., changing only data/ fields that are included in a source file while preserving all data/ fields not in the source file.

This would require a means of identifying fields that are protected from overlay on import.
Comment 1 Magnus Enger 2017-03-06 08:55:35 UTC
(In reply to Cab Vinton from comment #0)
> This would require a means of identifying fields that are protected from
> overlay on import.

Have you looked at "Bug 14957 - Write protecting MARC fields based on source of import"?
Comment 2 Katrin Fischer 2020-01-11 23:24:55 UTC

*** This bug has been marked as a duplicate of bug 14957 ***