Bug 18319 - Elasticsearch Advanced search breadcrumbs broken
Summary: Elasticsearch Advanced search breadcrumbs broken
Status: RESOLVED DUPLICATE of bug 22413
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-23 10:35 UTC by Nick Clemens
Modified: 2019-03-08 11:05 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2017-03-23 10:35:45 UTC
To recreate:
Perform an advanced search with more than one term

Get results but note that searchis not populated in breadcrumbs

Try to sort the results

You will be kicked in to an empty adv. search page
Comment 1 Nick Clemens 2019-02-07 12:55:00 UTC
It seems the query_desc and query_cgi calculations are wrong in the QueryBuilder

This also affects faceting on advanced searches and pagination
Comment 2 Ere Maijala 2019-03-08 11:05:16 UTC

*** This bug has been marked as a duplicate of bug 22413 ***