Bug 18487 - GetMemberAccountRecords returning imprecise amount - causing pay issue
Summary: GetMemberAccountRecords returning imprecise amount - causing pay issue
Status: RESOLVED DUPLICATE of bug 17140
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on: 3379
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-24 13:16 UTC by Nick Clemens
Modified: 2017-04-24 13:38 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 18487 - GetMemberAccountRecords returning imprecise amount - causing pay issue (2.13 KB, patch)
2017-04-24 13:32 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2017-04-24 13:16:53 UTC
To recreate:
Create a manual invoice for 7.56
Pay fines, 'pay amount'
Attempt to pay 7.56
You get an error "amount paid must be less than or equal to 7.56"
Verify you can pay 7.55 - or 7.57 if you owe 7.57, but not 7.56 if you owe 7.56

Turns out $total_due is being fetched as '7.5599'
Comment 1 Nick Clemens 2017-04-24 13:32:35 UTC
Created attachment 62600 [details] [review]
Bug 18487 - GetMemberAccountRecords returning imprecise amount - causing pay issue

To test:
1 - Create a manual fine of 7.56
2 - Attempt to 'pay amount' 7.56
3 - Error
4 - Apply patch
5 - payment should succeed
6 - prove t/db_dependent/Members.t
Comment 2 Nick Clemens 2017-04-24 13:38:31 UTC

*** This bug has been marked as a duplicate of bug 17140 ***