Bug 18518 - The staff interface "blink" for different actions after upgrading to Firefox 53
Summary: The staff interface "blink" for different actions after upgrading to Firefox 53
Status: RESOLVED DUPLICATE of bug 18551
Alias: None
Product: Koha
Classification: Unclassified
Component: Browser compatibility (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-01 14:39 UTC by Francois Charbonnier
Modified: 2017-05-08 14:45 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 18518: Hide patron list dialog by default (1.78 KB, patch)
2017-05-01 17:41 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 18518: Hide patron list dialog by default (1.82 KB, patch)
2017-05-03 17:29 UTC, Philippe Audet-Fortin
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Charbonnier 2017-05-01 14:39:39 UTC
After upgrading to firefox 53 (ubuntu 14.04) I noticed the interface "blinks" when I check out an item (on Koha 16.05)

I tried this with firefox 52, the interface stays still.

Marc Veron reproduced the issue on the current master :

- On the staff client main page, click on 'Patrons'
- While loading the page, I see very shortly a yellow message "Add patrons to" (I took a video and stepped through it to be able to read the text).
- Then the page refreshes and displays as expected.
- I get the same when I am on the page Home > Patrons and click 'Search'.

I get it with Firefox 53.0  (Windows)
I do not get it with Firefox ESR 45.3.0 (Debian)

Marc suggests the message "Add patrons to" should not be triggered.
Comment 1 Marc Véron 2017-05-01 16:28:27 UTC
Update: I could reproduce with Firefox ESR 45.3.0 (Debian) as well by slowing it down (turned on syspref DumpTemplateVarsIntranet, it consumes quite a lot of time).

I think the problem is related to document.ready

It contains hide() functions at several places. Maybe they could be rearranged (moved up to the top) where applicable.
Comment 2 Marc Véron 2017-05-01 17:39:49 UTC
OK, there are several elements hiding / unhiding, one of them is the patron lists dialog.
Comment 3 Marc Véron 2017-05-01 17:41:27 UTC
Created attachment 62927 [details] [review]
Bug 18518: Hide patron list dialog by default

This patch hides the patron list dialog by default to prevent it to
display shortly when koha/members/member.pl is called.

There are more reasons for the blinking of the page, but at least the
yellow patron list dialog does no longer display without having to.

To test:
- Slow down system by enabling syspref DumpTemplateVarsIntranet
- Try to reproduce issue, see a yellow dialog come up for a very
  short time when member.pl is displayed (e.g. with a search)
- Apply patch
- Go to patron page
- Try to reproduce. Page still blinks, but the dialog as one of
  the elements that produce bilnking does no longer show up
- Verify that patron list functionality works as before (Select some
  patrons and add them to a patron list).
Comment 4 Marc Véron 2017-05-01 17:48:53 UTC
The second reason for the blinking is that the form for the search filters shortly displays and then hides again. It moves the whole page down and up again.
Comment 5 Marc Véron 2017-05-01 19:41:06 UTC
It seems that the mechanism in following file is broken:
koha-tmpl/intranet-tmpl/prog/en/includes/patron-search.inc

To visualise, add a delay to all functions toggle(), e.g. toggle 500

You will see that the page first displays with the filter fields set to visible, and then they are turned off by the toggle function.

I can not find out how to fix.
Comment 6 Blou 2017-05-02 14:15:37 UTC
So the Koha code is not optimal.  But why does is suddenly show up in the new Firefox ?  It's just slower?

We'll be happy to signoff if you find a solution, Marc.
Comment 7 Marc Véron 2017-05-02 14:39:37 UTC
(In reply to Blou from comment #6)
> So the Koha code is not optimal.  But why does is suddenly show up in the
> new Firefox ?  It's just slower?
> 
> We'll be happy to signoff if you find a solution, Marc.

Hi Blou

The patch removes one of the issues (the yellow dialog shortly shining up).

For the other issue (comment #5) I did not find out how to fix.

Maybe it is a good idea you reach out to ICR.

Marc
Comment 8 Philippe Audet-Fortin 2017-05-03 17:29:42 UTC
Created attachment 63039 [details] [review]
Bug 18518: Hide patron list dialog by default

This patch hides the patron list dialog by default to prevent it to
display shortly when koha/members/member.pl is called.

There are more reasons for the blinking of the page, but at least the
yellow patron list dialog does no longer display without having to.

To test:
- Slow down system by enabling syspref DumpTemplateVarsIntranet
- Try to reproduce issue, see a yellow dialog come up for a very
  short time when member.pl is displayed (e.g. with a search)
- Apply patch
- Go to patron page
- Try to reproduce. Page still blinks, but the dialog as one of
  the elements that produce bilnking does no longer show up
- Verify that patron list functionality works as before (Select some
  patrons and add them to a patron list).

Signed-off-by: paudet <paudet@inlibro.com>
Comment 9 Marc Véron 2017-05-04 16:26:19 UTC
(In reply to Philippe Audet-Fortin from comment #8)
> Created attachment 63039 [details] [review] [review]
> Bug 18518: Hide patron list dialog by default
> 
(...)
> Signed-off-by: paudet <paudet@inlibro.com>

Philippe, did you forget to switch to signed off?
Comment 10 Fridolin Somers 2017-05-05 15:59:32 UTC
Oh I've proposed also a patch on Bug 18551.

I've also hidden the table.

Should I rebase my bug on this one or provide a followup in this one ?
Comment 11 Marc Véron 2017-05-06 09:00:58 UTC
(In reply to Fridolin SOMERS from comment #10)
> Oh I've proposed also a patch on Bug 18551.
> 
> I've also hidden the table.
> 
> Should I rebase my bug on this one or provide a followup in this one ?

It's OK for me to mark this bug as duplicate of 18551

*** This bug has been marked as a duplicate of bug 18551 ***