Bug 18684 - Translatability: Get rid of %%] in translation for currency.tt
Summary: Translatability: Get rid of %%] in translation for currency.tt
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Marc Véron
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 18662 18665
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-26 19:07 UTC by Marc Véron
Modified: 2017-11-09 12:11 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18684 - Get rid of %%] in translation for currency.tt (3.00 KB, patch)
2017-05-26 19:16 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 18684 - Get rid of %%] in translation for currency.tt (3.10 KB, patch)
2017-05-28 09:30 UTC, Alex Buckley
Details | Diff | Splinter Review
Bug 18684 - Get rid of %%] in translation for currency.tt (3.16 KB, patch)
2017-06-16 20:42 UTC, Brendan Gallagher
Details | Diff | Splinter Review
Bug 18684: (followup) Move 2 closing h3 tags to end of previous lines (1.55 KB, patch)
2017-06-19 20:48 UTC, Marc Véron
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2017-05-26 19:07:54 UTC
File add koha-tmpl/intranet-tmpl/prog/en/modules/admin/currency.tt exposes parts of template directives due to html tags inide directives. Fix it using the HtmlTags filter.
Comment 1 Marc Véron 2017-05-26 19:16:50 UTC
Created attachment 63753 [details] [review]
Bug 18684 - Get rid of %%] in translation for currency.tt

File add koha-tmpl/intranet-tmpl/prog/en/modules/admin/currency.tt exposes
parts of template directives due to html tags inide directives. Fix it using
the HtmlTags filter.

To verify:
- Create a translation for a language 'aa-AA
- po file aa-AA-staff-prog.po / translate.koha-community.org for 17.05 contains a line
  '%%]'%sCurrencies %s
To test:
- Apply patch on top of Bug 18665
- Recreate translation
- Verify that line above is gone
- Verify that in staff client currencies administration wors as before
Comment 2 Alex Buckley 2017-05-28 09:30:29 UTC
Created attachment 63769 [details] [review]
Bug 18684 - Get rid of %%] in translation for currency.tt

File add koha-tmpl/intranet-tmpl/prog/en/modules/admin/currency.tt exposes
parts of template directives due to html tags inide directives. Fix it using
the HtmlTags filter.

To verify:
- Create a translation for a language 'aa-AA
- po file aa-AA-staff-prog.po / translate.koha-community.org for 17.05 contains a line
  '%%]'%sCurrencies %s
To test:
- Apply patch on top of Bug 18665
- Recreate translation
- Verify that line above is gone
- Verify that in staff client currencies administration wors as before

Followed test plan and it worked as intended
Signed-off-by: Alex Buckley <alexbuckley@catalyst.net.nz>
Comment 3 Brendan Gallagher 2017-06-16 20:42:53 UTC
Created attachment 64418 [details] [review]
Bug 18684 - Get rid of %%] in translation for currency.tt

File add koha-tmpl/intranet-tmpl/prog/en/modules/admin/currency.tt exposes
parts of template directives due to html tags inide directives. Fix it using
the HtmlTags filter.

To verify:
- Create a translation for a language 'aa-AA
- po file aa-AA-staff-prog.po / translate.koha-community.org for 17.05 contains a line
  '%%]'%sCurrencies %s
To test:
- Apply patch on top of Bug 18665
- Recreate translation
- Verify that line above is gone
- Verify that in staff client currencies administration wors as before

Followed test plan and it worked as intended
Signed-off-by: Alex Buckley <alexbuckley@catalyst.net.nz>

Signed-off-by: Brendan A Gallagher <brendan@bywatersolutions.com>
Comment 4 Jonathan Druart 2017-06-19 18:46:03 UTC
Why the closing h3 tags is on a new line?
Comment 5 Marc Véron 2017-06-19 19:30:54 UTC
(In reply to Jonathan Druart from comment #4)
> Why the closing h3 tags is on a new line?

Seems to be a mistake?
How do you want it fixed? Amend patch or a follow-up.
Comment 6 Jonathan Druart 2017-06-19 19:50:09 UTC
follow-up please, I will squash them.
Comment 7 Marc Véron 2017-06-19 20:48:10 UTC
Created attachment 64442 [details] [review]
Bug 18684: (followup) Move 2 closing h3 tags to end of previous lines

See comment #4
Comment 8 Jonathan Druart 2017-06-21 14:28:02 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 9 Fridolin SOMERS 2017-06-29 07:24:56 UTC
Enhancement not pushed to 17.05.x

Depends on Bug 18665 which is not pushed into 17.05.x.