Bug 18749 - xt/sample notices fails with "No sample notice to delete"
Summary: xt/sample notices fails with "No sample notice to delete"
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Lee Jamison
QA Contact: Galen Charlton
URL:
Whiteboard:
Keywords:
Depends on: 17855
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 17:27 UTC by Lee Jamison
Modified: 2017-06-15 20:17 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18749 - xt/sample_notices.t fails (1.38 KB, patch)
2017-06-07 17:59 UTC, Lee Jamison
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 18749 - xt/sample_notices.t fails (1.45 KB, patch)
2017-06-11 08:07 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 18749 - xt/sample_notices.t fails (1.52 KB, patch)
2017-06-13 15:38 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lee Jamison 2017-06-07 17:27:40 UTC
Testing xt/sample_notices.t results in 11 test failures of "No sample notice to delete".
Comment 1 Lee Jamison 2017-06-07 17:59:21 UTC
Created attachment 64086 [details] [review]
Bug 18749 - xt/sample_notices.t fails

Bug Description:
When performing a unit test on xt/sample_notices.t with the command
'prove xt/sample_notices.t' 11 tests fail with the error message
"No sample notice to delete".

Cause of bug:
The failures are caused by an incorrect file path on Line 25 of
xt/sample_notices.t.

Patch Description:
This patch corrects the failures by changing $base_notices_file from
"en/default/sample_notices.sql" to "en/mandatory/sample_notices.sql"

Test Plan:
1) Drop into koha-shell and run the command 'prove xt/sample_notices.'
2) 11 unit tests fail.
3) Apply the patch.
4) Re-run 'prove xt/sample_notices.t'
5) All of the tests pass now.
6) Quit out of koha-shell
Comment 2 Josef Moravec 2017-06-11 08:07:29 UTC
Created attachment 64180 [details] [review]
[SIGNED-OFF] Bug 18749 - xt/sample_notices.t fails

Bug Description:
When performing a unit test on xt/sample_notices.t with the command
'prove xt/sample_notices.t' 11 tests fail with the error message
"No sample notice to delete".

Cause of bug:
The failures are caused by an incorrect file path on Line 25 of
xt/sample_notices.t.

Patch Description:
This patch corrects the failures by changing $base_notices_file from
"en/default/sample_notices.sql" to "en/mandatory/sample_notices.sql"

Test Plan:
1) Drop into koha-shell and run the command 'prove xt/sample_notices.'
2) 11 unit tests fail.
3) Apply the patch.
4) Re-run 'prove xt/sample_notices.t'
5) All of the tests pass now.
6) Quit out of koha-shell

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 3 Jonathan Druart 2017-06-13 15:38:16 UTC
Created attachment 64262 [details] [review]
Bug 18749 - xt/sample_notices.t fails

Bug Description:
When performing a unit test on xt/sample_notices.t with the command
'prove xt/sample_notices.t' 11 tests fail with the error message
"No sample notice to delete".

Cause of bug:
The failures are caused by an incorrect file path on Line 25 of
xt/sample_notices.t.

Patch Description:
This patch corrects the failures by changing $base_notices_file from
"en/default/sample_notices.sql" to "en/mandatory/sample_notices.sql"

Test Plan:
1) Drop into koha-shell and run the command 'prove xt/sample_notices.'
2) 11 unit tests fail.
3) Apply the patch.
4) Re-run 'prove xt/sample_notices.t'
5) All of the tests pass now.
6) Quit out of koha-shell

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 Jonathan Druart 2017-06-14 20:38:38 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 5 Fridolin SOMERS 2017-06-15 12:13:33 UTC
Pushed to 17.05.x, will be in 17.05.01
Comment 6 Katrin Fischer 2017-06-15 20:17:35 UTC
Depends on onboarding feature which is not in 16.11.x.