Bug 19046 - IntranetCatalogSearchPulldown doesn't retain last selection
Summary: IntranetCatalogSearchPulldown doesn't retain last selection
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 19152 (view as bug list)
Depends on: 14902
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-06 09:58 UTC by Nick Clemens
Modified: 2019-05-27 12:39 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 19046: Make seach pulldown to retain index selection (13.29 KB, patch)
2019-03-04 18:42 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19046: Make seach pulldown to retain index selection (13.34 KB, patch)
2019-03-08 20:10 UTC, Pierre-Marc Thibault
Details | Diff | Splinter Review
Bug 19046: Make seach pulldown to retain index selection (13.41 KB, patch)
2019-03-09 20:50 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19046: (QA follow-up) Remove doubled up 'Title as phrase' (1.24 KB, patch)
2019-03-09 20:50 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2017-08-06 09:58:40 UTC
On the OPAC if you have the pulldown enabled and perform a 'Title' search, this selection carries over. On the staff client the default is always 'Keyword'
Comment 1 Katrin Fischer 2017-08-18 16:43:21 UTC
*** Bug 19152 has been marked as a duplicate of this bug. ***
Comment 2 Karen 2017-08-18 16:45:30 UTC
One of our library partners was searching for a list of titles and wanted to use the Title option for each of her searches. She noticed that after every search she did using Title search option, the system always defaulted back to Keyword. 

The expected behavior is that the search option would stay on Title and not default back to Keyword each time.
Comment 3 Katrin Fischer 2019-02-10 18:01:14 UTC
Also the search term doesn't remain in the search box like it does in the OPAC. Still valid :(
Comment 4 Jonathan Druart 2019-03-04 18:42:18 UTC
Created attachment 86024 [details] [review]
Bug 19046: Make seach pulldown to retain index selection

This patch also fixes add the term in the search input

Test plan:
Enable IntranetCatalogSearchPulldown
Search for a term using the search input in the header (simple search)
Re-do selecting different indices

The selection must retain on the search result page.
Comment 5 Pierre-Marc Thibault 2019-03-08 20:10:26 UTC
Created attachment 86401 [details] [review]
Bug 19046: Make seach pulldown to retain index selection

This patch also fixes add the term in the search input

Test plan:
Enable IntranetCatalogSearchPulldown
Search for a term using the search input in the header (simple search)
Re-do selecting different indices

The selection must retain on the search result page.

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>
Comment 6 Katrin Fischer 2019-03-09 20:50:45 UTC
Created attachment 86416 [details] [review]
Bug 19046: Make seach pulldown to retain index selection

This patch also fixes add the term in the search input

Test plan:
Enable IntranetCatalogSearchPulldown
Search for a term using the search input in the header (simple search)
Re-do selecting different indices

The selection must retain on the search result page.

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Katrin Fischer 2019-03-09 20:50:49 UTC
Created attachment 86417 [details] [review]
Bug 19046: (QA follow-up) Remove doubled up 'Title as phrase'

One search option was doubled up by accident.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Nick Clemens 2019-03-11 13:10:49 UTC
Awesome work all!

Pushed to master for 19.05
Comment 9 Martin Renvoize 2019-03-12 08:51:38 UTC
Pushed to 18.11.x for 18.11.04
Comment 10 Lucas Gass 2019-03-15 17:31:02 UTC
backported to 18.05.x for 18.05.11