Bug 19067 - clubs/ is not correctly mapped in Makefile.PL
Summary: clubs/ is not correctly mapped in Makefile.PL
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 19352 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-09 15:25 UTC by Tomás Cohen Arazi
Modified: 2017-09-21 21:43 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19067: Map clubs/ into INTRANET_CGI_DIR in Makefile.PL (1.37 KB, patch)
2017-08-09 15:34 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 19067: Test Makefile.PL mapping (1.81 KB, patch)
2017-08-09 15:59 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED OFF] Bug 19067: Map clubs/ into INTRANET_CGI_DIR in Makefile.PL (1.44 KB, patch)
2017-08-09 18:30 UTC, Katrin Fischer
Details | Diff | Splinter Review
[SIGNED OFF] Bug 19067: Test Makefile.PL mapping (1.87 KB, patch)
2017-08-09 18:31 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 19067: Map clubs/ into INTRANET_CGI_DIR in Makefile.PL (1.51 KB, patch)
2017-08-10 14:27 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19067: Test Makefile.PL mapping (1.94 KB, patch)
2017-08-10 14:27 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2017-08-09 15:25:54 UTC
The clubs/ dir is not correctly mapped in Makefile.PL and thus not installed (on source installs and packages as well).

To reproduce:
- Run
  $ grep clubs Makefile.PL
=> FAIL: no reference to the dir
Comment 1 Tomás Cohen Arazi 2017-08-09 15:34:35 UTC
Created attachment 65762 [details] [review]
Bug 19067: Map clubs/ into INTRANET_CGI_DIR in Makefile.PL

This patch adds the required entry in Makefile.PL so the clubs/ dir is correctly installed
during the make install step.

To test:
- Run:
  $ cd kohaclone
  $ perl Makefile.PL
- Follow any install method and options
- Run
  $ make
  $ ls blib/INTRANET_CGI_DIR/ | grep clubs
=> FAIL: No clubs dir
- Run:
  $ make clean
- Apply this patch
- Run:
   $ perl Makefile.PL
- Follow any install method and options
- Run
  $ make
  $ ls blib/INTRANET_CGI_DIR/ | grep clubs
=> SUCCESS: The clubs/ dir is correctly picked for inclussion in the intranet cgi dir
- Sign off :-D
Comment 2 Jonathan Druart 2017-08-09 15:59:44 UTC
Created attachment 65765 [details] [review]
Bug 19067: Test Makefile.PL mapping
Comment 3 Katrin Fischer 2017-08-09 18:30:40 UTC
Created attachment 65774 [details] [review]
[SIGNED OFF] Bug 19067: Map clubs/ into INTRANET_CGI_DIR in Makefile.PL

This patch adds the required entry in Makefile.PL so the clubs/ dir is correctly installed
during the make install step.

To test:
- Run:
  $ cd kohaclone
  $ perl Makefile.PL
- Follow any install method and options
- Run
  $ make
  $ ls blib/INTRANET_CGI_DIR/ | grep clubs
=> FAIL: No clubs dir
- Run:
  $ make clean
- Apply this patch
- Run:
   $ perl Makefile.PL
- Follow any install method and options
- Run
  $ make
  $ ls blib/INTRANET_CGI_DIR/ | grep clubs
=> SUCCESS: The clubs/ dir is correctly picked for inclussion in the intranet cgi dir
- Sign off :-D

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Katrin Fischer 2017-08-09 18:31:10 UTC
I am upping severity - this bug means you can't use the hightlighted feature at all.
Comment 5 Katrin Fischer 2017-08-09 18:31:15 UTC
Created attachment 65775 [details] [review]
[SIGNED OFF] Bug 19067: Test Makefile.PL mapping

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Jonathan Druart 2017-08-10 14:27:03 UTC
Created attachment 65813 [details] [review]
Bug 19067: Map clubs/ into INTRANET_CGI_DIR in Makefile.PL

This patch adds the required entry in Makefile.PL so the clubs/ dir is correctly installed
during the make install step.

To test:
- Run:
  $ cd kohaclone
  $ perl Makefile.PL
- Follow any install method and options
- Run
  $ make
  $ ls blib/INTRANET_CGI_DIR/ | grep clubs
=> FAIL: No clubs dir
- Run:
  $ make clean
- Apply this patch
- Run:
   $ perl Makefile.PL
- Follow any install method and options
- Run
  $ make
  $ ls blib/INTRANET_CGI_DIR/ | grep clubs
=> SUCCESS: The clubs/ dir is correctly picked for inclussion in the intranet cgi dir
- Sign off :-D

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 7 Jonathan Druart 2017-08-10 14:27:08 UTC
Created attachment 65814 [details] [review]
Bug 19067: Test Makefile.PL mapping

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Jonathan Druart 2017-08-10 16:53:35 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 9 Fridolin SOMERS 2017-09-12 14:04:52 UTC
Pushed to 17.05.x, will be in 17.05.04.
Comment 10 Katrin Fischer 2017-09-15 23:25:08 UTC
No patron clubs in 16.11.x, so not needed there.
Comment 11 Katrin Fischer 2017-09-21 05:26:36 UTC
*** Bug 19352 has been marked as a duplicate of this bug. ***
Comment 12 Liz Rea 2017-09-21 21:11:34 UTC
Man it would have been nice if the symptom of this had been listed somewhere in the bug report.
Comment 13 Tomás Cohen Arazi 2017-09-21 21:43:39 UTC
(In reply to Liz Rea from comment #12)
> Man it would have been nice if the symptom of this had been listed somewhere
> in the bug report.

It would have been nice. Agreed