Bug 19344 - DB fields login_attempts and lang may be inverted
Summary: DB fields login_attempts and lang may be inverted
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Kyle M Hall
URL:
Whiteboard:
Keywords:
Depends on: 17762 18314
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-19 16:28 UTC by Jonathan Druart
Modified: 2017-10-29 18:24 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19344: Reorder lang and login_attempts in the [deleted]borrowers tables (1.13 KB, patch)
2017-09-19 16:35 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19344: Reorder lang and login_attempts in the [deleted]borrowers tables (1.18 KB, patch)
2017-09-19 17:46 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 19344: Reorder lang and login_attempts in the [deleted]borrowers tables (1.22 KB, patch)
2017-09-29 14:04 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2017-09-19 16:28:47 UTC
Due to a bad rebase, the borrowers and deletedborrowers table structure may different from a new install and upgraded install
Comment 1 Jonathan Druart 2017-09-19 16:35:09 UTC
Created attachment 67220 [details] [review]
Bug 19344: Reorder lang and login_attempts in the [deleted]borrowers tables

Due to a bad rebase, the borrowers and deletedborrowers table structure
may different from a new install and upgraded install
For new installs, the order was: lang, login_attempts
For upgraded installs, it was lang, last_seen, login_attempts

After this patch, the order must be:
- last_seen
- lang
- login_attempts
Comment 2 M. Tompsett 2017-09-19 17:45:30 UTC
Went back to 16.05 did drop/create and reset_all.
checked the DB, didn't see the fields in question, though they may have been ordered differently then.
changed to master, ran upgrade.
different order confirmed.
applied patch
order corrected.
drop/create and reset_all
check the DB, fields are in the expected order (with overdrive_auth_token at the end).
Comment 3 M. Tompsett 2017-09-19 17:46:31 UTC
Created attachment 67222 [details] [review]
Bug 19344: Reorder lang and login_attempts in the [deleted]borrowers tables

Due to a bad rebase, the borrowers and deletedborrowers table structure
may different from a new install and upgraded install
For new installs, the order was: lang, login_attempts
For upgraded installs, it was lang, last_seen, login_attempts

After this patch, the order must be:
- last_seen
- lang
- login_attempts

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Comment 4 Kyle M Hall 2017-09-29 14:04:29 UTC
Created attachment 67466 [details] [review]
Bug 19344: Reorder lang and login_attempts in the [deleted]borrowers tables

Due to a bad rebase, the borrowers and deletedborrowers table structure
may different from a new install and upgraded install
For new installs, the order was: lang, login_attempts
For upgraded installs, it was lang, last_seen, login_attempts

After this patch, the order must be:
- last_seen
- lang
- login_attempts

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Jonathan Druart 2017-09-29 20:18:58 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 6 Fridolin SOMERS 2017-10-27 12:13:53 UTC
Pushed to 17.05.x, will be in 17.05.06.
Comment 7 Katrin Fischer 2017-10-29 18:24:10 UTC
Both dependent bugs are not part of 16.11.x, so this should not be needed there. Closing.