Bug 19467 - Display location and itemtype description on lost items report
Summary: Display location and itemtype description on lost items report
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 20236 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-14 21:53 UTC by Katrin Fischer
Modified: 2018-06-04 20:15 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19467: Display description instead of code for itemtype and location (1.80 KB, patch)
2018-02-17 21:49 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19467: Display description instead of code for itemtype and location (1.85 KB, patch)
2018-03-13 09:50 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 19467: Display description instead of code for itemtype and location (1.99 KB, patch)
2018-03-23 18:32 UTC, Séverine Queune
Details | Diff | Splinter Review
Bug 19467: Display description instead of code for itemtype and location (2.06 KB, patch)
2018-03-25 09:50 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2017-10-14 21:53:03 UTC
The lost items report displays the location and itemtype codes instead of the descriptions.
Comment 1 Jonathan Druart 2017-10-18 13:21:20 UTC
I did it on bug 9573 for the lost status.
Comment 2 Katrin Fischer 2017-10-21 21:51:11 UTC
Solved by bug 9573.
Comment 3 Katrin Fischer 2018-02-17 17:24:53 UTC
Actually, it isn't and I just filed a new report... bug 20236
Comment 4 Jonathan Druart 2018-02-17 21:41:48 UTC
*** Bug 20236 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Druart 2018-02-17 21:43:01 UTC
Sorry for the confusion, what I meant on comment 1 was: I did it for the lost status and need to be done for locations and itemtypes.
Comment 6 Jonathan Druart 2018-02-17 21:49:48 UTC
Created attachment 71896 [details] [review]
Bug 19467: Display description instead of code for itemtype and location

On reports/itemslost.pl you must now see the descriptions instead of the
code for itemtype and location
Comment 7 Katrin Fischer 2018-02-18 10:27:21 UTC
(In reply to Jonathan Druart from comment #5)
> Sorry for the confusion, what I meant on comment 1 was: I did it for the
> lost status and need to be done for locations and itemtypes.

Don't worry, I think that was my mistake. :)
Comment 8 sandboxes@biblibre.com 2018-03-13 09:50:10 UTC
Patch tested with a sandbox, by delaye <stephane.delaye@biblibre.com>
Comment 9 sandboxes@biblibre.com 2018-03-13 09:50:32 UTC
Created attachment 72751 [details] [review]
Bug 19467: Display description instead of code for itemtype and location

On reports/itemslost.pl you must now see the descriptions instead of the
code for itemtype and location

Signed-off-by: delaye <stephane.delaye@biblibre.com>
Comment 10 Séverine Queune 2018-03-13 10:11:50 UTC
It works for itemptypes but not for locations.
Comment 11 Jonathan Druart 2018-03-23 17:35:59 UTC
(In reply to Séverine Queune from comment #10)
> It works for itemptypes but not for locations.

Works for me, can you double check please?
Comment 12 Séverine Queune 2018-03-23 18:32:40 UTC
Created attachment 73218 [details] [review]
Bug 19467: Display description instead of code for itemtype and location

On reports/itemslost.pl you must now see the descriptions instead of the
code for itemtype and location

Signed-off-by: delaye <stephane.delaye@biblibre.com>
Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>
Comment 13 Séverine Queune 2018-03-23 18:35:15 UTC
My bad, I was pretty sure I checked on the atuthorizes values which one was the code or the description, but it seeems I confused myself...
Sorry about that, it works !!
Comment 14 Katrin Fischer 2018-03-25 09:50:11 UTC
Created attachment 73227 [details] [review]
Bug 19467: Display description instead of code for itemtype and location

On reports/itemslost.pl you must now see the descriptions instead of the
code for itemtype and location

Signed-off-by: delaye <stephane.delaye@biblibre.com>
Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 15 Jonathan Druart 2018-03-26 20:35:20 UTC
Pushed to master for 18.05, thanks to everybody involved!