Bug 19669 - Remove deprecated checkouts by patron category report
Summary: Remove deprecated checkouts by patron category report
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Kyle M Hall
URL:
Whiteboard:
Keywords:
: 19665 19666 19667 19668 20368 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-21 13:49 UTC by Owen Leonard
Modified: 2018-06-04 20:15 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19669: Remove deprecated checkouts by patron category report (11.94 KB, patch)
2017-11-21 13:57 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19669: Remove deprecated checkouts by patron category report (11.94 KB, patch)
2017-11-28 00:10 UTC, Dilan Johnpullé
Details | Diff | Splinter Review
Bug 19669: Remove deprecated checkouts by patron category report (11.99 KB, patch)
2017-12-21 14:17 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 19669 [QA Followup] - Remove itemstypes.plugin (3.65 KB, patch)
2017-12-21 14:17 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2017-11-21 13:49:57 UTC
Koha has a report which isn't linked to from anywhere. A comment on Bug 840 says that the report is deprecated. I propose that thirteen years is enough of a wait and we should probably go ahead and remove it.
Comment 1 Owen Leonard 2017-11-21 13:57:58 UTC
Created attachment 69246 [details] [review]
Bug 19669: Remove deprecated checkouts by patron category report

The checkouts by patron category report has been hidden and considered
deprecated since 2004. This patch removes it.

To test, apply the patch and confirm that nothing at all seems to have
changed and everything feels fine.
Comment 2 Dilan Johnpullé 2017-11-28 00:10:35 UTC
Created attachment 69406 [details] [review]
Bug 19669: Remove deprecated checkouts by patron category report

Patch applies. Reports and general OPAC and staff client functionality is intact.
Signed-off-by: Dilan Johnpullé <dilan@calyx.net.au>
Comment 3 Owen Leonard 2017-11-29 12:54:01 UTC
*** Bug 19668 has been marked as a duplicate of this bug. ***
Comment 4 Owen Leonard 2017-11-29 12:54:04 UTC
*** Bug 19667 has been marked as a duplicate of this bug. ***
Comment 5 Owen Leonard 2017-11-29 12:54:07 UTC
*** Bug 19666 has been marked as a duplicate of this bug. ***
Comment 6 Owen Leonard 2017-11-29 12:54:11 UTC
*** Bug 19665 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Druart 2017-12-19 15:44:54 UTC
What about the other .plugin file (reports/itemtypes.plugin), see bug 3431 comment 2.
And then remove reports/manager.pl?
Is this plugin system used?
Comment 8 Kyle M Hall 2017-12-21 14:17:21 UTC
Created attachment 70029 [details] [review]
Bug 19669: Remove deprecated checkouts by patron category report

Patch applies. Reports and general OPAC and staff client functionality is intact.
Signed-off-by: Dilan Johnpullé <dilan@calyx.net.au>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 9 Kyle M Hall 2017-12-21 14:17:28 UTC
Created attachment 70030 [details] [review]
Bug 19669 [QA Followup] - Remove itemstypes.plugin

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 10 Jonathan Druart 2017-12-21 16:08:58 UTC
(In reply to Kyle M Hall from comment #9)
> Created attachment 70030 [details] [review] [review]
> Bug 19669 [QA Followup] - Remove itemstypes.plugin
> 
> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Kyle, Are you sure about that?
If yes we should remove it on a specific bug report, as well as the reports/manager.pl stuffs.
Comment 11 Jonathan Druart 2017-12-21 16:24:15 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 12 Nick Clemens 2018-01-15 13:14:23 UTC
Awesome work all! Pushed to stable for 17.11.02
Comment 13 Fridolin SOMERS 2018-01-15 14:46:34 UTC
Pushed to 17.05.x for v17.05.08
Comment 14 Victor Grousset/tuxayo 2018-01-26 09:26:50 UTC
Link for reports/itemtypes.plugin is stil in
staff:/cgi-bin/koha/reports/reports-home.pl
with the name "Catalog by itemtype"

New bug for this or do we use the current one?
Comment 15 Fridolin SOMERS 2018-01-26 11:32:07 UTC
(In reply to Victor Grousset/tuxayo from comment #14)
> Link for reports/itemtypes.plugin is stil in
> staff:/cgi-bin/koha/reports/reports-home.pl
> with the name "Catalog by itemtype"
> 
> New bug for this or do we use the current one?

I'd say new bug since this one has been released.
Comment 16 Jonathan Druart 2018-01-30 15:27:07 UTC
(In reply to Jonathan Druart from comment #10)
> (In reply to Kyle M Hall from comment #9)
> > Created attachment 70030 [details] [review] [review] [review]
> > Bug 19669 [QA Followup] - Remove itemstypes.plugin
> > 
> > Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
> 
> Kyle, Are you sure about that?
> If yes we should remove it on a specific bug report, as well as the
> reports/manager.pl stuffs.

Oops, I forgot to remove this commit before the push, I am going to revert it.
Comment 17 Nick Clemens 2018-02-02 17:03:49 UTC
(In reply to Jonathan Druart from comment #16)
> (In reply to Jonathan Druart from comment #10)
> > (In reply to Kyle M Hall from comment #9)
> > > Created attachment 70030 [details] [review] [review] [review] [review]
> > > Bug 19669 [QA Followup] - Remove itemstypes.plugin
> > > 
> > > Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
> > 
> > Kyle, Are you sure about that?
> > If yes we should remove it on a specific bug report, as well as the
> > reports/manager.pl stuffs.
> 
> Oops, I forgot to remove this commit before the push, I am going to revert
> it.

Reverted last patch for stable for 17.11.03
Comment 18 Fridolin SOMERS 2018-02-05 10:25:56 UTC
(In reply to Nick Clemens from comment #17)
> 
> Reverted last patch for stable for 17.11.03

Same for 17.05 then, reverted in v17.05.09
Comment 19 Victor Grousset/tuxayo 2018-02-07 08:23:22 UTC
Just for anyone else who might have also a doubt: it's indeed reverted in master (commit 7cb86656956131ed81cc74069a765a37664edd8e)
Comment 20 Nick Clemens 2018-03-12 14:59:35 UTC
*** Bug 20368 has been marked as a duplicate of this bug. ***