Bug 19705 - DecreaseLoanHighHolds.t is still failing randomly
Summary: DecreaseLoanHighHolds.t is still failing randomly
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 19423
Blocks: 25551 21086
  Show dependency treegraph
 
Reported: 2017-11-27 22:34 UTC by Jonathan Druart
Modified: 2020-06-19 17:06 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 19705: Try to fix random failures from DecreaseLoanHighHolds.t (1.24 KB, patch)
2018-01-23 20:01 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2017-11-27 22:34:43 UTC
https://jenkins.koha-community.org/job/Koha_Master_D8/298/console

#   Failed test 'Static mode should exceed threshold'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 125.
#          got: '0'
#     expected: '1'

#   Failed test 'Should have duration of 1'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 127.
#          got: '0'
#     expected: '1'

#   Failed test 'due_date should be a DateTime object'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 128.
#          got: ''
#     expected: 'DateTime'
Can't call method "hour" on an undefined value at t/db_dependent/DecreaseLoanHighHolds.t line 131.
# Looks like your test exited with 255 just after 5.
[18:52:27] t/db_dependent/DecreaseLoanHighHolds.t ......................... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 15/17 subtests
Comment 1 Jonathan Druart 2018-01-23 19:55:50 UTC
https://jenkins.koha-community.org/job/Koha_Master_D8/338/console

#   Failed test 'Static mode should exceed threshold'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 125.
#          got: '0'
#     expected: '1'

#   Failed test 'Should have duration of 1'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 127.
#          got: '0'
#     expected: '1'

#   Failed test 'due_date should be a DateTime object'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 128.
#          got: ''
#     expected: 'DateTime'
Can't call method "hour" on an undefined value at t/db_dependent/DecreaseLoanHighHolds.t line 131.
# Looks like your test exited with 255 just after 5.
[19:20:17] t/db_dependent/DecreaseLoanHighHolds.t ......................... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 15/17 subtests
Comment 2 Jonathan Druart 2018-01-23 20:01:08 UTC
Created attachment 70863 [details] [review]
Bug 19705: Try to fix random failures from DecreaseLoanHighHolds.t

No idea if it will do the trick, wait and see...
Comment 3 Jonathan Druart 2018-01-23 20:02:36 UTC
Pushed to master for 18.05
Comment 4 Nick Clemens 2018-02-02 17:03:03 UTC
Awesome work all! Pushed to stable for 17.11.03
Comment 5 Fridolin SOMERS 2018-02-05 10:28:27 UTC
Pushed to 17.05.x for v17.05.09
Comment 6 Jonathan Druart 2018-03-28 15:02:43 UTC
It did not work, still failing:

https://jenkins.koha-community.org/job/Koha_17.05_D8/lastCompletedBuild/console

#   Failed test 'Static mode should exceed threshold'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 130.
#          got: '0'
#     expected: '1'

#   Failed test 'Should have duration of 1'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 132.
#          got: '0'
#     expected: '1'

#   Failed test 'due_date should be a DateTime object'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 133.
#          got: ''
#     expected: 'DateTime'
Can't call method "hour" on an undefined value at t/db_dependent/DecreaseLoanHighHolds.t line 136.
# Looks like your test exited with 255 just after 5.
[12:10:51] t/db_dependent/DecreaseLoanHighHolds.t ......................... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 15/17 subtests 
[12:10:52] t/db_dependent/SIP/SI
Comment 7 Jonathan Druart 2019-06-28 18:13:35 UTC
Again, D9 run #795

koha_1       | #   Failed test 'Static mode should exceed threshold'
koha_1       | #   at t/db_dependent/DecreaseLoanHighHolds.t line 131.
koha_1       | #          got: '0'
koha_1       | #     expected: '1'
koha_1       | 
koha_1       | #   Failed test 'Should have duration of 1'
koha_1       | #   at t/db_dependent/DecreaseLoanHighHolds.t line 133.
koha_1       | #          got: '0'
koha_1       | #     expected: '1'
koha_1       | 
koha_1       | #   Failed test 'due_date should be a DateTime object'
koha_1       | #   at t/db_dependent/DecreaseLoanHighHolds.t line 134.
koha_1       | #          got: ''
koha_1       | #     expected: 'DateTime'
koha_1       | Can't call method "hour" on an undefined value at t/db_dependent/DecreaseLoanHighHolds.t line 137.
koha_1       | # Looks like your test exited with 11 just after 5.
koha_1       | [16:03:37] t/db_dependent/DecreaseLoanHighHolds.t
Comment 8 Victor Grousset/tuxayo 2020-06-11 15:17:01 UTC
After 188 local run I could reproduce on 19.05.x the failure that happening on this build:
https://jenkins.koha-community.org/view/19.05/job/Koha_19.05_D9/229/consoleText
 
t/db_dependent/DecreaseLoanHighHolds.t .. 2/17 
#   Failed test 'Static mode should exceed threshold'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 131.
#          got: '0'
#     expected: '1'

#   Failed test 'Should have duration of 1'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 133.
#          got: '0'
#     expected: '1'

#   Failed test 'due_date should be a DateTime object'
#   at t/db_dependent/DecreaseLoanHighHolds.t line 134.
#          got: ''
#     expected: 'DateTime'
Can't call method "hour" on an undefined value at t/db_dependent/DecreaseLoanHighHolds.t line 137.
# Looks like your test exited with 11 just after 5.
t/db_dependent/DecreaseLoanHighHolds.t .. Dubious, test returned 11 (wstat 2816, 0xb00)
Comment 9 Victor Grousset/tuxayo 2020-06-11 15:58:01 UTC
It was like 30 min, so not so hard to reproduce (assuming it wasn't huge luck)
Comment 10 Victor Grousset/tuxayo 2020-06-12 22:04:19 UTC
Happens also in Ubuntu 18.04 for 19.05.x branch. (if that can help)
https://jenkins.koha-community.org/job/Koha_19.05_U18/236/consoleText

It's the second time a few days. It's good that it's not a rare issue.
Comment 11 Jonathan Druart 2020-06-13 09:51:04 UTC
Victor, bug reports marked as pushed to a version that has been released already should not be reopened. Please open a new bug report instead.
Comment 12 Victor Grousset/tuxayo 2020-06-19 17:06:51 UTC
ok sorry, here it is: bug 25824