Bug 19843 - reviews.datereviewed is not set
Summary: reviews.datereviewed is not set
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Kyle M Hall
URL:
Whiteboard:
Keywords:
Depends on: 15839
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-19 19:53 UTC by Jonathan Druart
Modified: 2018-06-04 20:15 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19843: (bug 15839 follow-up) Set reviews.datereviewed when the review is made (1.19 KB, patch)
2017-12-19 19:55 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19843: (bug 15839 follow-up) Set reviews.datereviewed when the review is made (1.23 KB, patch)
2017-12-20 12:59 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19843: (bug 15839 follow-up) Set reviews.datereviewed when the review is made (1.29 KB, patch)
2017-12-21 11:30 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2017-12-19 19:53:14 UTC
Caused by
  commit 092ae340cef375cc66c8511fd34c1a4eec9c7ba6
    Bug 15839: Koha::Reviews - Remove savereview

the datereviewed=now() part of the query has not been translated.
Comment 1 Jonathan Druart 2017-12-19 19:55:58 UTC
Created attachment 69928 [details] [review]
Bug 19843: (bug 15839 follow-up) Set reviews.datereviewed when the review is made

Caused by
  commit 092ae340cef375cc66c8511fd34c1a4eec9c7ba6
    Bug 15839: Koha::Reviews - Remove savereview

the datereviewed=now() part of the query has not been translated.

Test plan:
Add a review from the OPAC
Confirm that the reviews.datereviewd has been correctly set. Without this patch
it is set to NULL.

I have no idea how we could update existing data :-/
Comment 2 Owen Leonard 2017-12-20 12:59:06 UTC
Created attachment 69948 [details] [review]
Bug 19843: (bug 15839 follow-up) Set reviews.datereviewed when the review is made

Caused by
  commit 092ae340cef375cc66c8511fd34c1a4eec9c7ba6
    Bug 15839: Koha::Reviews - Remove savereview

the datereviewed=now() part of the query has not been translated.

Test plan:
Add a review from the OPAC
Confirm that the reviews.datereviewd has been correctly set. Without
this patch it is set to NULL.

I have no idea how we could update existing data :-/

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Kyle M Hall 2017-12-21 11:30:41 UTC
Created attachment 70000 [details] [review]
Bug 19843: (bug 15839 follow-up) Set reviews.datereviewed when the review is made

Caused by
  commit 092ae340cef375cc66c8511fd34c1a4eec9c7ba6
    Bug 15839: Koha::Reviews - Remove savereview

the datereviewed=now() part of the query has not been translated.

Test plan:
Add a review from the OPAC
Confirm that the reviews.datereviewd has been correctly set. Without
this patch it is set to NULL.

I have no idea how we could update existing data :-/

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 4 Jonathan Druart 2017-12-21 14:30:22 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 5 Nick Clemens 2017-12-22 10:56:08 UTC
Pushed to stable for 17.11.01, awesome work all!