Bug 19878 - Move template JavaScript to the footer: UNIMARC editor plugins, part 7
Summary: Move template JavaScript to the footer: UNIMARC editor plugins, part 7
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords: Academy
Depends on: 19877
Blocks: 17858 19952
  Show dependency treegraph
 
Reported: 2017-12-22 18:04 UTC by Owen Leonard
Modified: 2018-04-23 22:51 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7 (25.55 KB, patch)
2018-01-02 16:38 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7 (26.93 KB, patch)
2018-03-14 14:12 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7 (27.01 KB, patch)
2018-03-15 13:03 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7 (27.07 KB, patch)
2018-03-25 18:53 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2017-12-22 18:04:13 UTC
Most UNIMARC plugin templates already have JavaScript at the bottom of the template instead of the top, but they should still be modified to be consistent with other templates which have been updated as part of Bug 17858.

This patch modifies the last of the UNIMARC editor plugins.
Comment 1 Owen Leonard 2018-01-02 16:38:26 UTC
Created attachment 70229 [details] [review]
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7

This patch updates the last of the UNIMARC plugin templates so that
JavaScript is included in the footer following the same pattern as
other templates which have been modified to fix Bug 17858.

To test you do not need a UNIMARC system.

Apply the patch and for each plugin, configure a MARC subfield (e.g.
100$a) to use that plugin.

From the MARC edit page, trigger the plugin and confirm that changes
made in the popup window are saved to the corresponding field in the
editor.

- unimarc_field_210c.tt
- unimarc_field_210c_bis.tt
- unimarc_field_225a.tt
- unimarc_field_225a_bis.tt
- unimarc_field_4XX.tt
- unimarc_field_700-4.tt
- unimarc_leader.tt
Comment 2 Olivier 2018-03-14 11:38:31 UTC
There is a problem with 4XX fields
On the pop-up window the link choose do nothing on click.

The others fields are ok.
Comment 3 Owen Leonard 2018-03-14 14:12:28 UTC
Created attachment 72870 [details] [review]
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7

This patch updates the last of the UNIMARC plugin templates so that
JavaScript is included in the footer following the same pattern as
other templates which have been modified to fix Bug 17858.

To test you do not need a UNIMARC system.

Apply the patch and for each plugin, configure a MARC subfield (e.g.
100$a) to use that plugin.

From the MARC edit page, trigger the plugin and confirm that changes
made in the popup window are saved to the corresponding field in the
editor.

- unimarc_field_210c.tt
- unimarc_field_210c_bis.tt
- unimarc_field_225a.tt
- unimarc_field_225a_bis.tt
- unimarc_field_4XX.tt
- unimarc_field_700-4.tt
- unimarc_leader.tt
Comment 4 Olivier 2018-03-14 16:04:09 UTC
Ok for 4XX
Ok for 210c_bis, ok for 225a_bis
but KO for 210c and 225a (drop down menu is empty)
all others fields works as expected
Comment 5 abernaud 2018-03-15 08:40:24 UTC
KO for 210c : search retrieves no result
Comment 6 Owen Leonard 2018-03-15 11:05:47 UTC
(In reply to Olivier from comment #4)

> but KO for 210c and 225a

I think this may be due to insufficient authorities data? Does it work any differently in master?

Thanks for testing!
Comment 7 Victor Grousset/tuxayo 2018-03-15 11:38:01 UTC
According to Olivier: It does the same on master. He will sign it off
Comment 8 sandboxes@biblibre.com 2018-03-15 13:03:11 UTC
Patch tested with a sandbox, by Anne-Claire Bernaudin <anne-claire.bernaudin@univ-rennes1.fr>
Comment 9 abernaud 2018-03-15 13:03:21 UTC
Not due to insufficient authorities data.
The problem is the same on Master.
Comment 10 sandboxes@biblibre.com 2018-03-15 13:03:34 UTC
Created attachment 72946 [details] [review]
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7

This patch updates the last of the UNIMARC plugin templates so that
JavaScript is included in the footer following the same pattern as
other templates which have been modified to fix Bug 17858.

To test you do not need a UNIMARC system.

Apply the patch and for each plugin, configure a MARC subfield (e.g.
100$a) to use that plugin.

From the MARC edit page, trigger the plugin and confirm that changes
made in the popup window are saved to the corresponding field in the
editor.

- unimarc_field_210c.tt
- unimarc_field_210c_bis.tt
- unimarc_field_225a.tt
- unimarc_field_225a_bis.tt
- unimarc_field_4XX.tt
- unimarc_field_700-4.tt
- unimarc_leader.tt

Signed-off-by: Anne-Claire Bernaudin <anne-claire.bernaudin@univ-rennes1.fr>
Comment 11 Katrin Fischer 2018-03-25 18:53:28 UTC
Created attachment 73254 [details] [review]
Bug 19878: Move template JavaScript to the footer: UNIMARC editor plugins, part 7

This patch updates the last of the UNIMARC plugin templates so that
JavaScript is included in the footer following the same pattern as
other templates which have been modified to fix Bug 17858.

To test you do not need a UNIMARC system.

Apply the patch and for each plugin, configure a MARC subfield (e.g.
100$a) to use that plugin.

From the MARC edit page, trigger the plugin and confirm that changes
made in the popup window are saved to the corresponding field in the
editor.

- unimarc_field_210c.tt
- unimarc_field_210c_bis.tt
- unimarc_field_225a.tt
- unimarc_field_225a_bis.tt
- unimarc_field_4XX.tt
- unimarc_field_700-4.tt
- unimarc_leader.tt

Signed-off-by: Anne-Claire Bernaudin <anne-claire.bernaudin@univ-rennes1.fr>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 12 Jonathan Druart 2018-03-26 20:36:30 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 13 Nick Clemens 2018-04-23 22:51:18 UTC
Awesome work all, enhancement, not backported for stable