Bug 19968 - Undefined subroutine &Date::Calc::Today
Summary: Undefined subroutine &Date::Calc::Today
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
: 19864 (view as bug list)
Depends on:
Blocks: 19866
  Show dependency treegraph
 
Reported: 2018-01-12 17:15 UTC by Jean-Daniel Tissot
Modified: 2018-06-04 20:15 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19968: Add missing use Date::Calc statement (1.04 KB, patch)
2018-01-15 13:12 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 19968: Add missing use Date::Calc statement (1.13 KB, patch)
2018-01-15 13:53 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Daniel Tissot 2018-01-12 17:15:36 UTC
Software error:

Undefined subroutine &Date::Calc::Today called at /usr/share/koha/intranet/cgi-bin/cataloguing/value_builder/unimarc_field_100.pl line 75.

Jonathan Druart propose to add "use Date::Calc;" after other use statements in file /usr/share/koha/intranet/cgi-bin/cataloguing/value_builder/unimarc_field_100.pl

After adding this line, the problem is solved.
Comment 1 Jean-Daniel Tissot 2018-01-12 17:18:56 UTC
OS is  Debian Jessie and Koha is installed from http://debian.koha-community.org/koha
Comment 2 Jonathan Druart 2018-01-15 13:12:05 UTC
Created attachment 70487 [details] [review]
Bug 19968: Add missing use Date::Calc statement

It has been reported than the missing use statement can cause a
compilation error:
Undefined subroutine &Date::Calc::Today called at
/usr/share/koha/intranet/cgi-bin/cataloguing/value_builder/unimarc_field_100.pl
line 75.

Test plan:
Use this UNIMARC plugin and make sure it fixes the error or at least
does not break it
Comment 3 Marcel de Rooy 2018-01-15 13:53:37 UTC
Created attachment 70488 [details] [review]
Bug 19968: Add missing use Date::Calc statement

It has been reported than the missing use statement can cause a
compilation error:
Undefined subroutine &Date::Calc::Today called at
/usr/share/koha/intranet/cgi-bin/cataloguing/value_builder/unimarc_field_100.pl
line 75.

Test plan:
Use this UNIMARC plugin and make sure it fixes the error or at least
does not break it

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 4 Marcel de Rooy 2018-01-15 13:54:11 UTC
SO en QA in one run
Comment 5 Marcel de Rooy 2018-01-15 13:54:26 UTC
(In reply to Marcel de Rooy from comment #4)
> SO en QA in one run

en = and
Comment 6 Jonathan Druart 2018-01-15 16:49:08 UTC
Patch pushed to master for 18.05.
Comment 7 M. Tompsett 2018-01-17 19:16:01 UTC
*** Bug 19864 has been marked as a duplicate of this bug. ***
Comment 8 Nick Clemens 2018-01-23 04:09:37 UTC
Awesome work all!

Pushed to Stable for 17.11.02
Comment 9 Fridolin SOMERS 2018-01-31 07:33:07 UTC
Pushed to 17.05.x for v17.05.09