Bug 20210 - Claimed Return
Summary: Claimed Return
Status: RESOLVED DUPLICATE of bug 14697
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jesse Maseto
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-15 13:44 UTC by Kyle M Hall
Modified: 2019-03-05 21:16 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2018-02-15 13:44:23 UTC
mark an item claimed returned via circulation
a check box on list of checkouts on patron record and check out screen
gray out/disable 'claimed return' status from lost menu on item detail page ? only perform this action from patron/circulation
sys pref to ask 'charge', 'don't charge', or 'ask for confirmation' when marking an item claimed returned
sys pref to say what 'lost' status is to be used for 'claimed returns' If no value 'claims returned' is off
sys pref to offer an option to alert staff somehow, after a set number of claimed returns
remove item from patron's current list of check outs
This should stop fines from accruing
keep basic information about the item on patron's record so you can track how many times they've said 'i returned that'
This should be a tab on the list of checkouts section on patron detail and checkout page all titles they have claimed in the past (even if they have since been returned or deleted)
ex. [title 1] / checked out {date} / claimed {date} / not returned / notes
[title 2] / checked out {date} / claimed {date} / found {date} / notes
Tab should show number of claimed returned items just as the checkout and hold tabs show counts
Show unprocessed claimed returns in red in this tab
show as missing in the opac and claimed returned in the staff client
be able to mark item as 'found' from claimed tab if item happens to be found
Offer options of ?returned by patron? or ?found in library? in a pull down to the side of every item that has been claimed.
claimed items should be easily distinguishable on staff side (compared to lost items)
on patron check out under 'Attention' alert 'Patron has claimed returns', if patron has claimed items that are not processed, that links to the 'Claimed' tab below
next to each claimed item have a 'notes' field for anything which should be editable and updatable.
Comment 1 Brian 2018-11-03 13:49:45 UTC
Any updates on bug 20210?

Carnegie Stout Staff would be grateful
Comment 2 Joy Nelson 2019-03-05 21:16:54 UTC

*** This bug has been marked as a duplicate of bug 14697 ***